
Welcome to TextAloud 

 
Welcome to TextAloud, the world's most popular Text To Speech tool. It uses voice synthesis to create 
spoken audio from text. You can listen on your PC or save text to MP3 or wave files for listening later. 
Even better, if you have a portable audio device you can take your text as MP3 files to the gym, in your 
car, or anyplace you need to go. 
 
Users range from lawyers listening to proofread contracts, to busy students getting through their assigned 
reading without the eye strain, to commuters listening to news or making their own audiobooks from 
ebooks. We get business people, educators, writers, speakers, and all kinds of people who soon find 
TextAloud to be an indispensable utility. TextAloud is a great tool for learning English. We also have 
many other languages plus a variety of natural sounding voices available to give your computer some 
real personality. Can your computer really sound like a human being without costing a fortune? Listen to 
samples of some of the premium voices we offer and you'll be surprised at the quality and value you can 
get with TextAloud. 
 
Do you or does someone you know need help using their computer because of a disability? TextAloud is 
popular for many Assistive Technology uses like low vision as well as dyslexia and other learning 
disabilities, etc. Anyone can try TextAloud for free and we often hear from people who tell us it's 
genuinely changed their lives. We also have a great site license program for schools and organizations 
interested in multiple copies. 
 
Maybe you're trying a Text To Speech product for the first time or just wondering what TextAloud can do 
for you? Check out the Getting Started section, or just send us an email now with your questions and 
watch how quickly we respond. We are truly dedicated to supporting our products and staying in tune with 
our customers so you'll be amazed at the personal service we provide. 
 
Features at a glance 

  Listen to articles one at a time, or build a playlist to listen to later.  

  Load articles using the Clipboard, Document Import, Hot Keys and Drag and Drop.  

  Support for Microsoft Word, Rich Text, WordPerfect, Open Office, PDF, HTML and XML documents.  

  Support for multiple Text-To-Speech engines, including international voices.  

  Support for WAV, MP3 and WMA audio files.  

  Proofread tool for listening to documents as you proofread.  

  Plugin toolbars for Microsoft Word, Internet Explorer, Outlook, Outlook Express, Windows Mail, and 

Firefox. 
 
Thanks for trying TextAloud, and don't forget to visit us at http://www.nextup.com  
 

 

Using TextAloud for the First Time 

 
After installing TextAloud, you can start speaking like this: 

  Type some text into the large area beneath the toolbars  

  Press the Speak button on the toolbar 
 
That's all there is to it.  You can go on now to the other "Getting Started" pages and see what TextAloud 
can do for you.  If you run into problems or have any questions at all, please contact us at 
support@nextup.com and we'll get back to you right away ! 
   



 

 

Listening to Selected Text 

 
TextAloud can speak text from any application on your computer that can write to the Windows 
Clipboard.  Follow these steps: 

  Use your mouse to select/highlight an area of text you want to listen to.  

  Press Ctrl+C.  (Press both keys at the same time)  

  You will be prompted by a Clipboard Prompt dialog, displayed at the bottom right of your screen.  

  On the prompt dialog, click the New button as the action.  

  You should now see an article in TextAloud containing the text you selected. 
 
To listen to the text, press the Speak button on the toolbar.  
 

 

Listening to Documents 

 
You can use TextAloud to listen to your documents.  To listen to a document, follow these steps: 

  Select File -> Open from the menu, or press the Open button on the toolbar.  

  Select a directory  

  Optionally select a file type from the bottom of the Open Dialog.  

  Select a file.  

  Press the Open button on the Open Dialog.  TextAloud will load the selected document as a new 

article.  

  To listen to the document, press the Speak button on the toolbar 
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Creating Audio Files 

 
TextAloud can generate audio files from articles you've loaded.  Available output formats include WAV, 
MP3, WMA and others.  To generate an audio file, follow these steps: 

  Load one or more articles into TextAloud.  

  From the menu, select Tools -> Audio File Options  

  Select the File Options panel  

  Choose an audio file format  

  Choose a Bit / Sample Rate setting.  

  Choose an output file directory  

  Press the OK button  

  From the main window, press the To File button in the toolbar. 
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Loading Articles 

 
The following methods are available to create articles in TextAloud: 

  Watch Clipboard  

  Watch Mouse  

  Document Import (File -> Open)  

  Import Hotkey  

  Drag And Drop  

  Windows Explorer "Open With TextAloud"  

  TextAloud Plugins 
 
To Create Articles Using the Windows Clipboard 
 
By default, TextAloud will monitor your Windows Clipboard and display a prompt whenever the clipboard 
is updated.  See Clipboard Options for information on how you can control the display of the clipboard 
prompt, and disable the prompt if necessary. 

  On the TextAloud Tools menu, enable Watch Clipboard if it is not already checked.  

  Use your mouse to select / highlight an area of text.  

  Press Ctrl+C  

  The TextAloud Clipboard Prompt will be displayed.  

  On the clipboard prompt, click the New button to create a new article, or the Append button to append 

the selected text to the current article. 
 
To Create Articles by selecting text with your mouse 
 
In addition to monitoring your system clipboard, TextAloud can monitor your mouse as you move it 
around the window, and detect when you have highlighted some text.  When you release your mouse 
button after making a text selection, TextAloud will display a prompt, and allow you to pick an action to 
perform with the selected text. 

  On the Textaloud Tools menu, enable Watch Mouse if it is not already checked.  

  Use your mouse to select / highlight an area of text.  

  The TextAloud Mouse Speak Prompt will be displayed.  

  On the mouse prompt, click the New button to create a new article, or the Append button to append 

the selected text to the current article. 
 
To Create Articles Using Document Import (File -> Open) 

  Press the Open button on the Standard Toolbar, or select File -> Open from the menu.  

  Select a directory.  

  Optionally select a file type from the bottom of the Open Dialog.  

  Select one or more files to open in TextAloud.  

  Press the Open button on the Open Dialog 
 
To Create Articles using an Import Hotkey 

  From the TextAloud Tools menu select Hotkey Setup.  

  Click Edit -> New Hotkey, or click the New Hotkey button on the toolbar.  



  In the New Hotkey dialog, select "Import Text" as the hotkey Action.  

  Choose the hotkey combination to assign, using the Hotkey field.  

  In the Text Source dropdown list select "Highlighted Text"  

  In the Copy Text To dropdown list select "New Article"  

  In the Voice dropdown list select a voice you would like to assign to the imported article, or select "Use 

TextAloud Voice" to have TextAloud select a voice for you.  

  Click the OK button.  

  Now that the hotkey has been created, use you mouse to select / highlight an area of text  

  Press your import hotkey. 
 
To Create Articles using Drag and Drop 
 
TextAloud articles can be created by dragging either selected text or a list of selected files and dropping 
the selection on the TextAloud main window. 

  Make sure the TextAloud main window is currently visible (not minimized).  

  Using your mouse, select / highlight an area of text in another application, or select one or more files in 

Windows Explorer.  

  Using your mouse, drag the selected text / selected files anywhere over the TextAloud window.  

  Release the mouse button. 
 
To Create Articles using the Windows Explorer Context Menu ("Open With TextAloud") 

  In Windows Explorer, select one or more document files supported by TextAloud.  See Importing 

Documents for the list of supported document formats.  

  Right click the selected file(s) to display the Windows Explorer popup menu.  

  Select "Open With TextAloud" from the popup menu. 
 
To Create Articles using TextAloud Plugins 
 
TextAloud currently has toolbar plugins for Internet Explorer, Firefox, Microsoft Word, Microsoft Outlook, 
and Outlook Express / Windows Mail.  Each toolbar has a button to import the document (or text 
selection) to a new TextAloud Article.  On any of the toolbars, click the Add Article button.  A new article 
will be created in the TextAloud window, and loaded with either the selected text (if a text selection has 
been made) or the entire document. 
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Configuring the User Interface 

 
There are several options available for configuring both appearance and how your keyboard is 
used.  This page describes how to configure the following: 

  Main Menu and Toolbars  

  Floating Toolbar  

  Article Font, Text Size and Colors  



  Article Tabs  

  Skins  

  Hotkeys  

  Keyboard Shortcuts 
 
Configuring the Main Menu and Toolbars 
 
Use the View menu to configure the main menu and toolbars.  Menu configuration options include 
whether to hide unused menu entries and whether icons should be displayed in the menus.  Toolbar 
configuration options include selecting which toolbars to display, toolbar styles, and button size. 
 
See TextAloud Toolbars for more advanced menu and toolbar customization. 
 
Configuring the Floating Toolbar 
 
The Floating Toolbar gives you access to convenient buttons on the main window toolbars while hiding 
the main window.  To configure the Floating Toolbar, click Tools -> TextAloud Options from the menu, 
and click the Miscellaneous Options tab.  On this tab you can configure when the Floating Toolbar should 
be displayed, the Floating Toolbar button size, whether button captions should be displayed, and if the 
Floating Toolbar should be forced to remain on top of other windows. 
 
Configuring Article Font, Text Size and Colors 
 
From the main menu, select Tools -> TextAloud Options and click the Font tab.  The Font tab allows 
you to select the font, text colors, background color and text size for articles displayed in the TextAloud 
window. 
 
Configuring Article Tabs 
 
From the main menu, select Tools -> TextAloud Options and click the Font tab.  In the Font dropdown 
list, select "Article Tabs".  You can then configure the font, text colors, background color and text size for 
article titles displayed in the article tabs. 
 
To help distinguish between adjacent tabs, TextAloud will automatically shade alternating tabs.  The 
alternate shading is calculated as a percentage (either lighter or darker) than the selected tab color.  To 
control the shading, select Tools -> TextAloud Options, and click the Article Options tab. Set the field 
labeled Alternate Tab Shading to the desired shading percentage. 
 
Changing TextAloud Appearance using Skins 
 
Skins allow you to completely change the look and feel of the TextAloud user interface.  Predefined skins 
can change everything from color the look and feel of window controls like radio buttons and 
checkboxes.  To configure skins, select Skins from the View menu, and choose from the list of displayed 
skins.  Use the Test button on the Skins dialog to get an idea of what each skin looks like. 
 
Configuring Hotkeys 
 
Hotkeys allow access to TextAloud functions from other applications.  There are two different kinds of 
hotkeys in TextAloud.  The Hotkey Setup window is used to set up hotkeys for speaking, proofreading, 
and importing text from external applications.  In addition, hotkeys can be configured to quickly change 
the default voice, and the default language.  The Advanced Toolbar Customization window can be used 
to assign system wide hotkeys to TextAloud menu entries.  Note that since Pause/Resume and Stop are 



items in the TextAloud menus, hotkeys are assigned to Pause/Resume and Stop using Advanced Toolbar 
Customization instead of Hotkey Setup. 
 
Configuring Keyboard Shortcuts 
 
Keyboard Shortcuts are assigned using Advanced Toolbar Customization.  The process of assigning 
keyboard shortcuts to hotkeys is similar to assigning system wide hotkeys to menu entries.   
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Archiving and Unarchiving Articles 

 
TextAloud can optionally archive articles when they are deleted.  If archiving is enabled, whenever one or 
more articles are deleted from TextAloud, the articles are removed from the TextAloud window moved to 
an archive.  Articles in the archive can be reloaded into the TextAloud window at any time.  An option is 
also available to specify the maximum number of days articles should be retained in the archive, at which 
point they are automatically purged from the archive. 
 
Configuring Archiving Options 
 
To control the archiving feature in TextAloud, click TextAloud Options on the TextAloud Tools menu, 
and click the Article Options tab.  Use the checkbox labeled "Archive Deleted Articles" to turn archiving on 
and off.  To automatically purge old articles from the archive, select the checkbox labeled "Delete articles 
from archive older than", and specify the number of days articles should remain in the archive. 
 
Unarchiving Articles 
 
To move previously archived articles back into the TextAloud window, select Unarchive from the File 
menu.  Select one or more articles from the list of archived articles, and press OK to unarchive the 
articles. 
 
Emptying the Archive 
 
If you wish to remove all currently archived articles, click Empty Archive from the File menu.  Note that 
this will permanently delete all articles from the archive.  
 

 

Importing Documents 

 
Use File -> Open, or the Open button on the toolbar to import documents into TextAloud. 
 
TextAloud currently supports the following document types: 



Document Type  File Extension  

Text File  .txt  

Word Document  .doc and .docx  

WordPerfect Document  .wpd  

OpenOffice.org OpenDocument  .odt  

PDF Document  .pdf  

Rich Text Format  .rtf  

HTML Document  .html  

XML Document  .xml  
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When importing a very large document into TextAloud, you can use the File Splitter utility to split the 
document into many small articles.  The File Splitter utility allows you to split the document using criteria 
you specify, and optionally load each 'split' into a TextAloud article automatically. 
.  
 

 

Proofreading Documents 

 
Using Vocal Proofreading 
Vocal Proofreading is a function in TextAloud that allows you to select text in any application, popup a 
proofreader window containing the selected text, and proofread the text by listening to the text as it is 
spoken aloud.  The proofreader window can be launched with TextAloud hotkeys, or from the Clipboard 
and Mouse Speak Prompt dialogs. 
 
Configuring TextAloud Hotkeys to launch Vocal Proofreading 

  From the TextAloud Tools menu select Hotkey Setup.  

  Click Edit -> New Hotkey, or click the New Hotkey button on the toolbar.  

  In the New Hotkey dialog, select "Vocal Proofread" as the hotkey Action.  

  Choose the hotkey combination to assign, using the Hotkey field.  

  In the Hotkey Options box at the bottom of the dialog, set Text Source to "Highlighted Text", and select 

the voice you would like to use for Vocal Proofreading.  

  Click the OK button. 
 
To proofread text using your hotkey, highlight text in any application and press the key combination 
assigned as the hotkey. 
 
Launching Vocal Proofreading from the Clipboard Prompt 

  Beneath the TextAloud Tools menu, enable the menu entry labeled "Watch Clipboard".  

  Highlight text in any application.  

  Press Ctrl+C to copy the text to the Windows Clipboard.  

  When the TextAloud Clipboard Prompt is displayed, select Vocal Proofread in the Action dropdown list, 

and click the Perform button. 
 
Launching Vocal Proofreading from the Mouse Speak Prompt 

  Beneath the TextAloud Tools menu, enable the menu entry labeled "Watch Mouse".  



  Select text in any application, and release the left mouse button  

  When the TextAloud Mouse Speak Prompt is displayed, select Vocal Proofread in the Action dropdown 

list, and click the Perform button. 
 
Vocal Proofreading is defined in TextAloud as a speaking Profile, meaning that some speaking 
configuration options can be tailored specifically when TextAloud is speaking text from the Vocal 
Proofreader window. 
 
To configure Character Speaking and Filtering for Vocal Proofreading 

  From the TextAloud Tools menu, select Character Speaking And Filtering.  

  Click Edit -> Add, or click the Add button on the toolbar.  

  In the Profile dropdown list, select Vocal Proofreading.  

  Select an option from the Option dropdown list (Filter Character, Speak Character, Play Sound).  

  Make sure the "Active" checkbox is selected  

  In the Characters field, enter a list of characters  

  If the Play Sound option is being used, you will also need to supply the name of a sound file (mp3, 

wma or wav file) to be played when the character is encountered in the text.  

  Press the OK button to close the dialog.  

  You may add multiple Character Speaking and Filtering entries for the Vocal Proofreading profile.  So 

one entry may be used to filter characters, anther entry may be created to speak certain characters, and 
another entry may specify a sound file to be played for some characters. 
 
To configure Automatic Text Insertions for Vocal Proofreading 

  From the TextAloud Tools menu, select Automatic Text Insertions.  

  Click Edit -> Add or click the Add button on the toolbar.  

  In the Profile dropdown list, select Vocal Proofreading.  

  in the Type of Insertion dropdown list, select what you would like to have inserted 

automatically.  Options include Pauses, Audio Clips and free form text.  

  In the Insert At dropdown list, select where you would like the text automatically inserted.  

  Depending on the type of insertion, you will then need to indicate the pause value, and audio clip, or 

free form text you want inserted.  

  Press the OK button to close the dialog.  

  You may add as many entries as you like. 
 

 
Using Step Proofreading 
Step Proofreading is another form of proofreading available in TextAloud.  Unlike Vocal Proofreading, 
which has its own window, Step Proofreading takes place in a TextAloud article.  Step Proofreading 
involves loading an article into TextAloud, and using the Step Navigations beneath the Navigations menu. 
 
When a Step Navigation is selected from the Navigations menu, TextAloud switches from its normal 
speaking Profile to the Step Proofreading profile.  This means that some TextAloud speaking options can 
be configured specifically for the Step Proofreading mode.  Once the selected Step Navigation has 
completed, TextAloud enters a Pause state.  When speaking is paused your options are to either select 
another Step Navigation, and step again, or click Resume.  Clicking Resume causes TextAloud to exit 
Step Navigation mode, and switch back to normal speaking.  
 
Using Step Proofreading in TextAloud 

  Load an article into TextAloud.  



  Begin speaking the article.  

  When ready to begin Step Proofreading, select any Step Navigation from the Navigations menu.  

  TextAloud will skip forward or backward, depending on the step navigation selected, switch to the Step 

Navigation profile, speak the desired text, and Pause 
 
To configure Character Speaking and Filtering for Step Proofreading 

  From the TextAloud Tools menu, select Character Speaking And Filtering.  

  Click Edit -> Add, or click the Add button on the toolbar.  

  In the Profile dropdown list, select Step Proofreading.  

  Select an option from the Option dropdown list (Filter Character, Speak Character, Play Sound).  

  Make sure the "Active" checkbox is selected  

  In the Characters field, enter a list of characters  

  If the Play Sound option is being used, you will also need to supply the name of a sound file (mp3, 

wma or wav file) to be played when the character is encountered in the text.  

  Press the OK button to close the dialog.  

  You may add multiple Character Speaking and Filtering entries for the Step Proofreading profile.  So 

one entry may be used to filter characters, anther entry may be created to speak certain characters, and 
another entry may specify a sound file to be played for some characters. 
 
To configure Automatic Text Insertions for Vocal Proofreading 

  From the TextAloud Tools menu, select Automatic Text Insertions.  

  Click Edit -> Add or click the Add button on the toolbar.  

  In the Profile dropdown list, select Step Proofreading.  

  in the Type of Insertion dropdown list, select what you would like to have inserted 

automatically.  Options include Pauses, Audio Clips and free form text.  

  In the Insert At dropdown list, select where you would like the text automatically inserted.  

  Depending on the type of insertion, you will then need to indicate the pause value, and audio clip, or 

free form text you want inserted.  

  Press the OK button to close the dialog.  

  You may add as many entries as you like.  
 

 

Editing Pronunciations 

 
When listening to text, it is fairly common to notice that voices will sometimes mispronounce 
words.  Some voices will perform better than others as far as handling pronunciations, but no voice is 
perfect. Very specialized vocabularies, such as legal, financial and medical terminology, can be 
particularly troublesome.   
 
In addition to dealing with mispronunciations when listening to text, it is also common to run across 
conditions where you would like some text to be ignored.  For example, a document may contain header 
and/or footer information, including elements such as dates, page numbers, and so on.  When listening to 
the document, it may be preferable to suppress speaking this information. 
 
The way to handle these kinds of problems is with Pronunciation Dictionary Maintenance, located under 
the TextAloud Tools menu.  This utility allows you to create pronunciation Dictionaries, which are simply 
groups of pronunciation corrections. 
 



Dictionaries and Dictionary Entries 
 
Pronunciation Dictionary Maintenance works by allowing you to create one or more Dictionaries, where 
each dictionary contains one or more Dictionary Entries.  There is no limit on the number of Dictionaries 
you can create, or the number of Dictionary Entries in each Dictionary. 
 
A Dictionary Entry represents a single pronunciation correction.  The Dictionary Entry contains a word or 
pattern to search for in the text, and indicates a substitution that should be performed for each 
match.  The Dictionary Entry also specifies whether the text / pattern match should be case sensitive, and 
whether word boundaries are required for a match. 
 
A Dictionary is a collection of Dictionary Entries.  It is up to you whether you want to have one dictionary 
or many dictionaries; there are two main reasons for grouping Dictionary Entries into multiple Dictionaries: 
 
1. It is possible to activate and deactivate Dictionaries.  This makes it possible to group Dictionary Entries 
by some context, such as medical, legal and technical terminology.  You have the option of activating and 
deactivating dictionaries based on the text being spoken. 
 
2. Dictionaries can be associated with specific languages, speech engine vendors, and even specific 
voices.  If you're having pronunciation problems with a specific voice, you can create a dictionary and 
associate it with the voice you're having trouble with.  Any dictionary entries added to this dictionary will 
be applied only when this specific voice is used; the dictionary entries will not interfere with other voices 
that are handling problem pronunciations correctly.  Similarly, if a dictionary is associated with a specific 
language, pronunciations will be applied only when a voice for the specified language is speaking. 
 
Searching Text and Substituting Corrections 
 
Dictionary Entries can be configured to scan text using simple text strings, masks, and regular 
expressions.  Masks and Regular Expressions allow you to search for complex patterns in the text, and 
substitute a correction at each occurrence of the pattern. 
 
Dictionary Entries provide several options for the substitution to be performed at each simple text string or 
pattern.  The most common type of substitution is 'Respell'; this option simply replaces a word that is not 
being pronounced correctly with an alternate spelling.  For example, if a speech engine is having trouble 
pronouncing the word "laugh", a dictionary entry can be used to respell each occurrence of "laugh" as 
"laf". 
 
Another common type of Dictionary Entry correction is to actually skip text.  When Skip Text is used, the 
dictionary entry will scan text for the simple text string or pattern associated with the entry, and remove 
any matching text.  Skip Text can be used if there is a character or set of characters that are not being 
pronounced correctly, or if the text contains information such as header information or page numbers that 
you do not want to hear spoken. 
 
Other substitution options include "Spell Text" and "Phonemes".  Occasionally you'll find acronyms that 
cause pronunciation problems, because the speech engine will treat the acronym as a word, pronouncing 
it rather than spelling it out.  This is a perfect example of when you would want to use Spell Text as a 
pronunciation correction. 
 
Phonemes can be thought of as the smallest units of sound that a speech engine is capable of 
making.  When you use a Dictionary Entry to correct a pronunciation using phoneme substitutions, you'll 
use a Phoneme Helper dialog to specify the exact pronunciation of word, using sets of phonemes.  Each 
language has its own set of phonemes, so in order to use Phoneme corrections, a language and dialect 
must be associated with either the Dictionary Entry or owning Dictionary. 



 
Phoneme pronunciation support from Dictionary Maintenance is limited to SAPI5 voices only.  SAPI4 
voices will ignore dictionary entries that use Phoneme pronunciation corrections. 
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Using Bookmarks 

 
Bookmarks are special tags recognized by TextAloud used for marking positions in an article.  Bookmarks 
can be used to help with editing long articles, and also for skipping portions of text when speaking the 
article aloud. 
 
Bookmarks have the following format: 
 
{{Bookmark=My Bookmark}} 
 
To Create A Bookmark in an Article 

  Position the cursor to the location where the bookmark should be inserted, and click the left mouse 

button.  

  Click the right mouse button to display the article's popup menu  

  Select "Add Bookmark" from the menu.  

  In the prompt displayed, enter a name to identify the bookmark.  You will receive an error if the name 

has already been used for a different bookmark in the article. 
 
To Skip to a Bookmark 

  Click the right mouse button to display the article's popup menu  

  Select "Skip to Bookmark" from the menu.  The bookmarks created for the article will appear as a 

submenu.  

  Select a bookmark from the submenu. 
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The Skip To Bookmark menu entry is disabled when writing text to audio files.  The entry is available only 
when TextAloud is not currently speaking, and when speaking text aloud.  
 

 

Using Comments 

 
Comments are sections of text in an article that are ignored when speaking an article aloud or to an audio 
file.  You can use comment tags for any purpose; for example, you may include comments in an article to 
indicate where the article text was obtained, the date the article was created, and so on. 
 



Comment tags have the following format: 
 
{{//this is a comment}} 
 
To Insert a Comment in an Article 

  Position the cursor to the location where the bookmark should be inserted, and click the left mouse 

button.  

  From the TextAloud main menu, select Insert Tags -> Comment  

  When prompted for the comment text, enter your comment and press the OK button. 
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When removing tags from selected text in an article using Insert Tags -> Remove Tags, the text in any 
comment tags will be uncommented instead of removed.  
 

 

Inserting Pauses 

 
Pause tags may be inserted into TextAloud articles, causing voices to pause for an interval you 
specify.  In addition, TextAloud can be configured to automatically generate pauses at the end of each 
sentence and/or paragraph. 
 
Pause tags have the following format: 
 
{{Pause=2}} 
 
The pause tag above represents a 2 second pause. 
 

 
To Insert a Pause Manually 

  Using your mouse, position the cursor to a location in the article where a pause should be inserted, and 

press the left mouse button.  

  Press the right button on your mouse to display the article's popup menu.  

  From the popup menu, select "Pause".  

  In the dialog displayed, enter the number of seconds you would like to pause.  You may use decimal 

values, such as .5 and 0.5. 
 
To Generate Pauses Automatically 
 
To have TextAloud automatically insert pauses at the end of sentences and/or paragraphs, use the 
Automatic Text Insertions dialog.  See the help on using this dialog.  
 

 

Using Voice Change Tags 

 
Voice change tags are used to cause TextAloud to change voices while speaking an article.  These tags 
may be used when speaking article text aloud or to an audio file, and are commonly used to create a 
"dialog" effect as text is spoken.  Alternating between a male and female voice can make a long passage 
of text easier to listen to. 
 



Voice change tags are supported only for SAPI5 voices.  SAPI4 voice engines will ignore these tags. 
 
Using Voice Change Tags 

  Position your mouse cursor to the location in the article where you would like to change voices, and 

click the left mouse button.  

  Right click to display the article's popup menu.  

  Select "Voice Change".  Available SAPI5 voices will appear as a submenu.  

  Select a voice from the submenu. 
 
Using Dynamic Voice Change Tags 
 
Dynamic voice change tags allow you to change voices when speaking without requesting a specific 
voice.  When inserting the tag, Instead of indicating a specific voice you would like to use, you instead 
indicate how TextAloud should dynamically select the voice for you.  Available Dynamic Voice Change 
tags are: 

  Random  

  Random Male  

  Random Female  

  Round Robin  

  Round Robin Male  

  Round Robin Female 
 
The actual voice selected for a Dynamic Voice Change tag is determined when the article is actually 
spoken.  So Dynamic Voice Change tags for an article will more than likely choose different voices each 
time an article is spoken, giving the article a different sound each time you listen. 
 
To insert a Dynamic Voice Change tag in an article: 

  Position your mouse cursor to the location in the article where you would like to change voices, and 

click the left mouse button.  

  Right click to display the article's popup menu.  

  Select "Dynamic Voice Change".  

  Select a Dynamic Voice Change tag from the submenu. 
 
Speed, Pitch and Volume settings when changing voices 
 
When using the voice change tags described on this page, there is currently no relationship between the 
voice selected and the speed, pitch and volume settings on the Voice Options panel.  This means that the 
current speed, pitch and volume settings remain in effect when a voice change tag is encountered.  If you 
need speed, pitch or volume to change along with the voice change, you will need to insert these as 
separate tags; see Using Speed, Pitch and Volume Tags. 
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If you have voices for multiple languages installed, Random and Round Robin voices in Dynamic Voice 
Change tags will be selected based on the current Default Language setting on the Voice Options panel.  
 

 

Using Speed, Pitch and Volume Tags 

 
For voices that support SAPI5, xml tags may be inserted in the text to control Speed, Pitch and 



Volume.  This gives you the ability to have Speed, Pitch and Volume vary as text is spoken.  For Speed 
and Pitch, tags are available to control either absolute or relative values.  For example, setting the 
'absolute' speed sets the speed to a specific value, while setting the 'relative' speed will increase or 
decrease the current speed by the value specified. 
 
Volume change tags in the text are always 'absolute' values; there is no tag for relative volume changes. 
 
Absolute values for Speed and Pitch range from -30 to 30, where 0 is the default. 
 
Values for Volume tags range from 0 to 100, where 100 is the maximum volume for the voice.  Note that 
Volume tags have no effect on your system volume.  Each SAPI5 voice has a volume setting which can 
be controlled independently of your system volume.   
 
The default Speed, Pitch and Volume settings can be controlled for each voice on the Voice Options 
panel.  Using Speed, Pitch and Volume tags in an article will temporarily override settings on the Voice 
Options panel, but does not change the settings.  In other words, using Speed, Pitch and Volume tags in 
an article has no effect on the default settings for a voice. 
 
End Tags 
 
End tags can be used to mark the end of a speed, pitch, or volume change.  For example, using an End 
Tag for a speed change causes the speed to return to whatever speed was in use before the change 
occurred. 
 
The Insert Tags menu contains entries for inserting Absolute Speed, Relative Speed, Absolute Pitch, 
Relative Pitch, and Volume tags.  When any of these menu entries are selected, a change tag is inserted 
at the current cursor position.  If text is selected in the article when the tag is inserted, a trailing End Tag 
will be inserted at the end of the selected text. 
 
If an End Tag is not used, the change remains in effect for the remainder of the article, unless another 
change is encountered. 
 
The following examples illustrate how multiple absolute speed changes can occur in an article, with and 
without end tags. 
 
Example 1 - In this example, the article contains multiple absolute speed changes tags.  No end tags are 
used. 
 
This text is spoken at the default speed.  <rate absspeed="3">This text is spoken at speed 3.  <rate 
absspeed="4">This text is spoken at speed 4. 
 
Example 2 - In this example, an End Tag is used with speed change tag, making the speed change 
temporary. 
 
This text is spoken at the default speed.  <rate absspeed="3">This text is spoken at speed 3. </rate> This 
text is spoken at the default speed. 
 
The table below gives examples of using each of the available speed, pitch and volume tags, along with 
associated End Tags. 

Sample Tag  Description  

<rate absspeed="3">  Set absolute speed to 3  



<rate speed="1">  Set relative speed to 1 (adds 1 to current speed)  

</rate>  Speed End Tag. Resets speed to value in use before last 
speed change.  

<pitch absmiddle="3">  Set absolute pitch to 3  

<pitch middle="1">  Set relative pitch to 1 (adds 1 to current pitch)  

</pitch>  Pitch End Tag. Resets pitch to value in use before last 
pitch change.  

<volume level="100">  Set voice volume to 100 (maximum volume)  

</volume>  Volume End Tag. Resets volume to value in use before 
last volume change.  

 

 
Missing image: tdoc4.bmpNote 
Pitch change tags work only for voices that support pitch adjustments.  Pitch change tags are typically 
ignored by a voice if pitch adjustment is not supported.  
 

 

Using Spell Tags 

 
SAPI5 voices support a tag which forces words to be spelled out, instead of pronounced as individual 
words.  Spell tags are ignored by SAPI4 voices. 
 
The Insert Tags menu contains a Spell entry for inserting spell tags in an article.  If text is selected in the 
article when the tag is inserted, a trailing End Tag will be inserted at the end of the selected text.  All text 
between the spell tag and its associated end tag will be spelled out. 
 
Here is an example illustrating how the spell tag is used: 
 
This text will be read normally.  <spell>This text will be spelled out.</spell>  This text will be read 
normally.  
 

 

Inserting Audio Clips 

 
It is possible to embed audio clips in TextAloud articles by selecting Audio Clip from the Insert Tags 
menu.  An audio clip can be any mp3, wma or wav file. 
 
When speaking text aloud, TextAloud will suspend speaking when the audio clip tag is reached, play the 
audio clip, and resume speaking.  When writing audio files, the audio specified by the clip tag will be 
embedded in the audio file created by TextAloud. 
 
Audio clip tags have the following format: 
 
{{Audio=C:\My Sounds\My Audio Clip.mp3}}  
 

 

Using Split Tags 

 



Split tags allow you to specify that when writing audio files, the audio should be split into multiple 
files.  When writing text to an audio file and a split tag is encountered, the current audio file is closed, and 
a new audio file started.  An article may contain any number of split tags.  Split tags are ignored when 
speaking an article aloud. 
 
There are two split tags formats available: 
 
Automatically generated split names 
 
{{Split}} 
 
In this form, TextAloud automatically generates a new file name for the split.  Split file names are 
generated by appending a sequence number to the article title.  So if the title of the article is "MyTitle", 
audio file names created by multiple {{Split}} tags would be MyTitle_001.mp3, MyTitle_002.mp3, 
MyTitle_003.mp3, and so on. 
 
User specified split names 
 
{{Split=MySplitName}} 
 
In this form, you specify your own split name instead of using automatically generated names.  For the 
split tag {{Split=MySplitName}}, audio will be split at the tag, and the name of new audio file will be 
MySplitName.mp3. 
 
Missing image: tdoc4.bmpNote 
Split audio files are always created in the Audio Output Directory, specified on the File Options 
tab.  There is not a way to splt audio files into different directories. 
 
Missing image: tdoc4.bmpNote 
Valid characters for user specified split names include alphanumeric characters and the underscore 
character. 
 
To insert a split tag in an article, select Split Audio File from the Insert Tags menu. A prompt will appear 
asking if you want TextAloud to generate a split file name automatically, or specify your own split name.  
 

 

TextAloud Main Window 

 
The TextAloud main window is depicted below: 
 
Missing image: ta main window.png 
 

 
Numbered areas on the picture above indicate key areas, and are described below. 
 
1. Main Menu 
Provides menu items to all functions available in TextAloud.  Most menu items have shortcut keys 
defined, and using Tools -> Advanced Toolbar Customization allows you to customize keyboard 
shortcuts.  The main menu is described in detail here.  
 
2. Toolbars 



Toolbars provide quick access to commonly used menu items.  Pause your mouse over an icon and a 
popup hint will provide a description of the icon's function.  There are several different toolbars available 
in TextAloud, and the toolbars are completely configurable.  Under the View menu, click Toolbar 
Options to customize which toolbars are displayed (including predefined toolbar groups), toolbar styles, 
button size, and choose whether or not do display button captions.  You can also change button icons by 
using Tools -> Advanced Toolbar Customization. The toolbars are described in detail here. 
 
3. Current Article Toolbar 
This is a special toolbar that contains controls associated with the current article.  The fields on the 
toolbar include the article title, the voice assigned to the article, and slider controls for speed, pitch and 
volume. 
 
4. Article List Dropdown 
Click this dropdown list to see the full list of all articles currently in TextAloud, then select an article title to 
load it into the main window.  Since articles are displayed in individual tabs, the display of this dropdown 
is completely optional.  The dropdown can be hidden by toggling the menu entry Display Article List 
Dropdown, under the View menu. 
 
5. Article Tabs 
Each article in TextAloud is displayed in a separate tab.  Tabs can be reordered by left clicking a tab, 
holding the left mouse button down, and dragging the tab to a new position.  Also, you can quickly edit 
article titles by double clicking the article tab.  The font, size, foreground color and background color for 
the tabs can be configured on the Font Options dialog.  Click Tools -> TextAloud Options, and click the 
Font tab. 
 
6. TextAloud Text Area 
This area is where text of the current article is displayed.  When manually creating an article, type or 
paste in this area.  You may edit text in this area, and several actions are available on a popup menu 
when you right-click in this area.  The font, size, foreground color and background color for the text area 
can be configured on the Font Options dialog.  Click Tools -> TextAloud Options, and click the Font 
tab. 
 
7. Status Bar 
The status bar at the bottom of the window will often provide helpful status information such as the 
number of current articles or progress indicators during speaking. 
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Screen Reader Compatibility Mode 

 
The default main menu and toolbar system used by TextAloud is not compatible with screen readers.  If 
you are using screen reader software, switch to Screen Reader Compatibility Mode (from the TextAloud 
View menu).  In Screen Reader Compatibility Mode, TextAloud uses an alternate main menu / toolbar 
system that is compliant with screen reader software. 
 
The following features are not available when running TextAloud in Screen Reader Compatibility Mode. 

  Automatic Hiding of unused menu items.  



  Popup menu customization  

  Toolbar Styles  

  Predefined Toolbar Groups  

  Configurable Toolbar Button sizes 
 
Menu items under the View menu related to these functions will not be visible when running TextAloud in 
Screen Reader Compatibility Mode. 
 

 

 

 

TextAloud Main Menu 

 
All actions in TextAloud are available from the main menu.  Each TextAloud menu entry is described 
below. 
 

File Menu 
Open - Loads a document into the TextAloud window.  See Importing Documents. 
New Article - Creates a new, blank article. 
Save Article As Text File - Prompts you for the name and location of a text file, and saves the current 
article to this text file. 
Save All Articles As Text Files - Prompts you for a directory, and saves all currently loaded TextAloud 
articles as text files in the directory.  Article titles are used to generate filenames. 
Unarchive - Displays a list of currently archived articles, and allows you to unarchive one or more 
articles.  Any unarchived articles are moved from the archive to the TextAloud main window.  See 
Archiving and Unarchiving Articles. 
Empty Archive - Deletes all articles from the archive.  See Archiving and Unarchiving Articles. 
Exit - Exits the TextAloud application 
 

Edit Menu 
Undo - When editing a TextAloud article, the Undo action removes the last change made, and restores 
the document to its previous state.  
Redo - Redo is the opposite of Undo.  Redo restores an edit that was removed with Undo. 
Cut - Removes selected text from the current TextAloud article and places it on the Windows Clipboard. 
Copy - Copies selected text from the current TextAloud article and places it on the Windows Clipboard. 
Paste - Replaces text currently selected in TextAloud with the contents of the Windows Clipboard.  If 
there is no text selection, the contents of the Clipboard are inserted at the current cursor position. 
Select All - Selects all text in the current TextAloud article. 
Search - Displays a dialog that allows you to search for text.  The search dialog gives you the option of 
searching all articles, or limiting the search to the current article. 
Repeat Search - Repeats the last search, starting at the current cursor position. 
Replace - Displays a dialog that allows you to search for text and replace it. 
Edit Article Title - Displays a dialog that allows you to change the title for the current article. 
Delete Current Article - Deletes the current TextAloud article.  If archiving is enabled, a copy of the 
article will be kept in the archive. See Archiving and Unarchiving Articles. 
Delete All Articles - Deletes all articles from TextAloud.  If archiving is enabled, a copy of each article will 
be kept in the archive. See Archiving and Unarchiving Articles. 
 

View Menu 
Hide Unused Menu Items - When this option is selected, only recently used items will be displayed when 
a menu is displayed.  An arrow will be displayed at the bottom of the menu when items are hidden, and 
hidden items can be displayed by clicking the arrow. 



Reset Menu Usage - Clicking this menu item removes all previously collected menu usage data.  If the 
option to Hide Unused Menu Items is selected, any menu items currently hidden will be displayed, and 
records of menu item usage are reset. 
Display Icons in Menus - Select this option to display icons in TextAloud menus. 
Display Article List Dropdown - Select this option to display the Article List dropdown in the TextAloud 
main window.  See TextAloud Main Window. 
Skins - Displays a dialog that allows you to 'skin' the TextAloud window.  See Changing TextAloud 
Appearance Using Skins. 
Screen Reader Compatibility Mode - By default, the TextAloud main menu and toolbars are not 
currently compatible with screen readers.  Clicking Screen Reader Compatibility Mode causes TextAloud 
to use an alternate main menu / toolbar system that is screen reader compatible.  See Screen Reader 
Compatibility Mode.  
Toolbars - Allows you to configure which TextAloud toolbars are displayed in the window.  See 
TextAloud Toolbars. 
Predefined Toolbar Groups - Allows you pick different configurations of toolbars to display.  The choices 
available are Classic, Pro, and Advanced; we generally recommend using the Classic setting.  See 
TextAloud Toolbars for more details on predefined groups. 
Toolbar Style - Allows you to apply different styles to the toolbars.  Each style gives a different look to the 
TextAloud toolbars and menus. 
Toolbar Button Size - Allows you to select between small, medium, and large toolbar buttons. 
Show Toolbar Button Captions - This option controls whether not button captions should be displayed 
on TextAloud toolbars.  Note that if captions are not displayed, you can hover your mouse over each 
button to display a button hint. 
Reset Toolbars - Allows you to undo all toolbar customizations, and restore toolbars in the main window 
to their initial state.  See Customizing Toolbars and Menus. 
Reset Popup Menus - Allows you to undo all Popup Menu customizations.  This will restore both the 
Main Window and Tray Icon popup menus to their initial state.  See Customizing Toolbars and Menus. 
 

Insert Tags Menu 
Each menu item beneath the Insert Tags menu is used to place a tag at the current cursor position.  The 
items under the Insert Tags menu are summarized here, but see Using Tags for more detailed 
information. 
Pause - Prompts for the number of seconds to pause, and inserts a tag in the text that causes speaking 
to pause when the tag is reached. 
Dynamic Voice Change - Inserts a tag in the text that causes the voice to change when the tag is 
reached.  TextAloud will automatically choose the new voice to use based on the tag selection. 
Voice Change - Inserts a tag in the text that causes TextAloud to switch to a voice you select when the 
tag is reached.  
Absolute Speed - Specify a new speed value to use when the tag is reached. 
Relative Speed - Increase or decrease the current speed by the value indicated when the tag is 
reached.  
Absolute Pitch - Specify a new pitch value to use when the tag is reached. 
Relative Pitch - Increase or decrease the current pitch by the value specified when the tag is reached. 
Volume - Specify a new volume value to use.  Use this tag when passages of text should be read louder 
than others. 
Audio Clip - Inserts the name of an audio file that is played when the tag is reached. 
Split Audio File - When writing audio files, split tags allow you indicate spots in the text where audio files 
should be split.  Split tags allow you to split the content of a large article into several audio files. 
Spell - Any text enclosed in a Spell tag will be spelled out, letter by letter. 
Bookmark - Places a bookmark tag in the text.  Use Skip To Bookmark, under the Navigation menu, to 
skip to any of the bookmarks defined for the current article. 
Comment - Places a comment tag in the text.  Any text in the comment tag is not spoken. 
Remove Tags - Removes any tags found in the current in the current text selection.  Any text contained 
in Comment tags is uncommented instead of removed. 
 



Speak Menu 
Items under the Speak Menu are used to initiate speaking, pause and stop, and adjust speed and pitch 
for the voice assigned to the current article.  The Speak Menu is divided into four, collapsible sections, 
allowing you to easily hide and display groups of items as needed. 
 
Current Article 
The items beneath the Current Article menu are used to initiate speak requests for the current 
article.  Use Speak Current Article Aloud or Speak Current Article To File to listen to the current 
article, or generate an audio file for the current article.  Speak From Cursor can be used to start 
speaking at the current cursor location instead of from the start.  So if you want to skip some portion of 
text, click to the sport where you want to start speaking and select either Speak From Cursor Aloud or 
Speak From Cursor To File.  You may also speak only a portion of an article.  Highlight a portion of text 
within the current article and select either Speak Selected Text Aloud or Speak Selected Text to File. 
 
In addition, the entries Loop Speak Current Article and Loop Speak Selected Text can be used to 
speak all or part of the current article, where speaking 'loops' each time the end of text is reached. 
 
All Articles 
The items beneath the All Articles menu are used to initiate speak requests for all articles currently loaded 
in the TextAloud window.  Use Speak All Articles Aloud or Speak All Articles To File to listen to all 
articles, or generate an audio file for each article.  You can optionally have speaking begin with any 
article, at any position in the article.  Select the article where you would like speaking to begin, position 
the cursor, and select either Speak All Articles From Cursor Aloud or Speak All Articles From Cursor 
To File. 
 
Control Speaking 
Items beneath the Control Speaking menu are available to Pause and Resume speaking, or Stop 
speaking. 
 
Control Voice  
Items beneath the Control Voice menu are available to Increment and Decrement Speed and/or 
Pitch.  Menu entries related to changing pitch are enabled only if the voice supports pitch control. 
 

Navigation Menu 
Items beneath the Navigation menu allow you to skip positions within articles and move between 
articles.  The items are divided into three, collapsible sections, allowing you to easily hide and display 
groups of items as needed. 
 
Within Article Navigations 
Within article navigations allow you to skip forward and backward within an article.  If TextAloud is 
speaking when these navigations are used, speaking will stop and resume at the new position.  Within 
article navigations allow you to skip to the next/previous line, paragraph, or screen.   You can also skip 
forward or backward in the current article in groups of 25, 50 or 100 lines. 
 
If the article contains bookmarks, there is an additional within article navigation called Skip To Bookmark 
that allows you to skip to any bookmark in the current article.  Use Bookmark under the Insert Tags 
menu to create bookmarks in an article. 
 
Between Article Navigations 
Between article navigations allow you to skip between articles.  If TextAloud is speaking when these 
navigations are used, speaking will stop and resume at the new position.  Between article navigations 
allow you to skip the First, Next, Previous or Last article. 
 



Step Navigations 
Step Navigations are used to enable a special proofreading mode in TextAloud called Step 
Proofreading.  For a detailed description of Step Proofreading, see Using Step Proofreading.  Whenever 
a Step Navigation is used, TextAloud will enter Step Proofreading mode, speak the desired text, and 
pause.  From the Pause state, you can either step again, or Resume to resume normal speaking.  Step 
Navigations allow you to step both forward and backwards.  The text spoken in a single step can be a full 
screen of text, a paragraph, line, word or a single letter. 
 

Tools Menu 
Items beneath the Tools menu are used for controlling TextAloud configuration settings and launching 
TextAloud utilities. 
TextAloud Options - Displays a tab panel providing access to Article Options, Font Options, Highlighting 
Options and Miscellaneous Options. 
Voice Options - Displays the Voice Options dialog. 
Audio File Options - Displays a tab panel providing access to File Encoding Options, Custom Encoders, 
Audio File Tags and Background Audio. 
Hotkey Setup - Displays the Hotkey Setup Dialog. 
Clipboard and Mouse Speak Options - Displays a tab panel providing access to Clipboard Options and 
Mouse Speak Options. 
Character Speaking and Filtering - Displays the Character Speaking and Filtering dialog. 
Automatic Text Insertions - Displays the Automatic Text Insertions dialog. 
Event Setup - Displays the Event Setup dialog. 
Configure Spell Check - Displays the Configure Spell Check dialog. 
Perform Spell Check - Performs a spell check on the currently selected text.  If no text is selected, a 
spell check is performed on the entire article. 
Watch Clipboard - Toggles the option to watch the Windows Clipboard.  See Clipboard Options. 
Watch Mouse - Toggles the option to watch your mouse.  See Mouse Speak Options. 
Advanced Toolbar Customization - Displays the Advanced Toolbar Customization dialog. 
Pronunciation Dictionary Maintenance - Displays the Pronunciation Dictionary Maintenance dialog. 
File Splitter Utility - Displays the File Splitter Utility dialog. 
Batch File Converter - Displays the Batch File Converter dialog. 
TextAloud Setup Wizard 
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  When sight impaired users are using TextAloud in combination with a screen reader, some items under 

the View menu can interfere with screen readers.  The Skins setting should be set to None, and the 
option Display Icons in Menus should not be selected. 
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TextAloud Toolbars 

 
Items in the TextAloud menus are organized into several toolbars.  The toolbars are organized by 
function, and a default set of buttons is configured to display on each toolbar.  You can configure both the 
toolbars displayed, as well as the individual buttons displayed on each toolbar. 
 
The following toolbars are available in the TextAloud main window: 
 
Standard - Contains Buttons for 'Standard' TextAloud actions.  Standard actions include actions like Cut, 
Copy, Paste, File Open, and other actions commonly used in Windows applications.  The buttons on the 



toolbar correspond to items on the File and Edit menus. 
 
Speak - The Speak toolbar contains buttons related to speaking the currently displayed article in the 
TextAloud window.  The buttons on this toolbar correspond to items in the Current Article section of the 
Speak Menu. 
 
Control Voice - The Control Voice toolbar contains buttons for the menu entries in the Control Voice 
section of the Speak Menu.  The buttons on this toolbar allow you to easily increment and/or decrement 
speed and pitch for the current voice. 
 
Multi Article Speak - The buttons on the Multi Article Speak toolbar correspond the menu items available 
in the All Articles section of the Speak Menu.  The buttons on this toolbar are used when you want to 
speak multiple articles loaded in the TextAloud window, either aloud or to audio files. 
 
Within Article Navigations - This buttons on this toolbar correspond to the Within Article Navigations 
section of the Navigations Menu.  Within Article Navigations allow you to skip forward and backward 
within a TextAloud article. 
 
Between Article Navigations - The buttons on this toolbar correspond to the Between Article 
Navigations section of the Navigations Menu. Between Article Navigations allow you to skip between 
articles. 
 
Step Navigations - Buttons on the Step Navigations toolbar correspond to items in the Step Navigations 
section of the Navigations Menu.  Step Navigations initiate a special proofreading mode in TextAloud 
called Step Proofreading. 
 
Tags - Buttons on the Tags toolbar correspond to items under the Insert Tags menu.  Tag buttons allow 
you to create various kinds of tags in the text, including Pauses, Bookmarks, Voice attribute adjustments, 
and others. 
 
Current Article - The Current Article toolbar is a toolbar containing several window controls related to the 
current article.  The fields available on the Current Article toolbar include the Article Title, the Voice 
currently assigned to the article, and slider controls for adjusting Speed, Pitch and Volume for the current 
voice. 
 
To change which toolbars are displayed in the TextAloud window, click the View menu, expand the 
Toolbar Options section, and click Toolbars to display and change the toolbars currently visible in the 
window. 
 
Predefined Toolbar Groups 
 
TextAloud includes some predefined toolbar groupings. To switch to different toolbar groups, click the 
View menu, expand the Toolbar Options section, and click Predefined Toolbar Groups.  Predefined 
Toolbar Groups are configured as follows: 

Toolbar Group  Toolbars  

Classic  Standard 
Speak 
Current Article  

Pro  Standard 
Speak 
Multi Article Speak 
Within Article Navigations  



Between Article Navigations 
Tags 
Current Article  

Advanced  Standard 
Speak 
Control Voice 
Multi Article Speak 
Within Article Navigations  
Between Article Navigations 
Step Navigations 
Tags 
Current Article  

 

 

 
Customizing Toolbars and Menus 
 
As mentioned above, you can select which toolbars are visible in the TextAloud window by selecting 
Toolbars from the Toolbar Options section of the View menu. 
 
Additional toolbar customizations are available by right clicking any toolbar, or clicking the small 
dropdown arrow at the far right of each toolbar.  This will display a popup menu that allows you to perform 
the following: 
 
Add or Remove Buttons - To add or remove buttons from a toolbar, just check / uncheck the buttons 
displayed beneath the Add or Remove Buttons menu. 
 
Reset Toolbar - Resets the toolbar to its initial, default state. 
 
Customizing Mode - Click the menu entry labeled "Customizing ..." to enter a special toolbar customizing 
mode.  You will be in customizing mode for as long as the Customizing dialog is displayed.  While in 
Customizing mode, you can perform the following: 

  Drag buttons between toolbars  

  Right click any button, and from the popup menu displayed, delete the button, change the button 

caption, or change the button image.  

  From the Customize Dialog, click the Commands tab, and drag any TextAloud action to any existing 

toolbar.  

  Use the Customize Dialog to create your own, custom toolbars.  Click the "New" button on the Toolbars 

tab, enter a name for your toolbar and press OK.  Then, click the Commands tab, and drag any TextAloud 
actions to your custom toolbar.  You can also drag buttons that already appear on other toolbars, moving 
them to your custom toolbar.  

  Customize the main menu by expanding any main menu entry, and drag items off the menu, drag 

items between menus, or drag TextAloud actions from the Customizing Dialog Commands tab to any 
menu. 
 
To exit Customizing Mode, simply close the Customize dialog. 
 
It is also possible to customize the popup menu displayed by right clicking in the TextAloud article area, 
as well as the popup menu displayed by right clicking the TextAloud tray icon.  From the article popup 
menu, click Customize Popup Menu and you will enter the same Customizing Mode described 
above.  Similarly, you can enter Customizing Mode for the tray icon popup menu by right clicking the tray 
icon and selecting Customize Tray Icon Menu.  While in Customizing mode for either popup menu, you 



can remove menu entries from the popup menu, drag menu entries or toolbar buttons between the 
TextAloud main window and the popup menu, and drag actions from the Customizing Dialog Commands 
tab to the popup menu. 
 
Resetting Toolbars and Menus 
 
Customizations performed to the TextAloud Toolbars and Popup menus can be undone at any time, and 
the toolbars / popup menus returned to their default settings.  There are two actions beneath the View 
menu available for this: Reset Toolbars and Reset Popup Menus.  The Reset Toolbars action will reset 
the toolbars and main menu to their default state.  The Reset Popup Menus action will reset both the 
article popup menu and tray icon popup menu to their initial, default state.  
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Vocal Proofreader Window 
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The Vocal Proofreader window allows you to proofread text by letting you listen to small sections of text at 
a time.  The Vocal Proofreader window can be launched from a system wide hotkey, or from either the 
Clipboard or Mouse Speak Prompt dialogs.  See Proofreading Documents for instructions on how to 
configure launching the Vocal Proofreader window. 
 
There are several controls available in the panel beneath the text area in the proofreader window that 
allow you to configure proofreader window options. 
 
To change the voice used for vocal proofreading, change the voice in the voice dropdown list. 
 
Use the Speed slider to change the proofreading speed. 
 
If the checkbox labeled "Close Window When Speaking Finished" is selected, the proofreader window will 
close automatically when proofreading is finished. 
 
Use the dropdown list labeled "When Window is Clicked" to control what happens when the proofreader 
window is clicked.  Available options are to either close the proofreader window, or to Pause / Resume 
speaking. 
 
Click the Options button to display options to control Font, Text Size, and Colors in the proofreader 
window, and to configure Word Highlighting. 
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Clipboard Prompt 
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The Clipboard Prompt is displayed when the option Watch Clipboard is enabled, and you copy text from 



an application to the Windows Clipboard.  When the prompt is displayed, you can select an action from a 
dropdown list of available actions, or click the Ignore button to ignore the clipboard update. 
 
Actions available from the Clipboard Prompt 
 
The following actions may be selected from the Clipboard Prompt: 
 
Add New Article - Use this action to add a new TextAloud article and load it with the text currently on the 
Windows Clipboard 
 
Insert Text At Top of Article - Inserts the text currently on the windows clipboard at the top of the current 
TextAloud article 
 
Insert Text At Current Cursor Position - Inserts the text currently on the windows clipboard at the 
current cursor position in the current TextAloud Article. 
 
Append Text to Bottom of Article - Appends the text currently on the windows clipboard to the bottom 
of the current TextAloud article. 
 
Speak Text - Speaks the text currently on the Windows Clipboard 
 
Vocal Proofread - Opens the Vocal Proofread window, loads the window with the current clipboard text, 
and begins proofreading. 
 

 
Configuring the Clipboard Prompt 
 
The Clipboard Prompt can be configured from the Clipboard Options dialog, available under the 
TextAloud Tools menu.  Some configuration options may also be set by clicking the Show Details link on 
the prompt. 
 
The following configuration options are available when Show Details is clicked: 

Field  Description  

Display Prompt For  Specifies the number of seconds the clipboard prompt will 
display before automatically closing.  

Set Last Action As 
Default Action  

When this option is selected, when an action is selected from 
the clipboard prompt, that action becomes the default action.  

Perform Action 
Automatically On 
Timeout  

Specifies whether or not the Default Action should be 
performed automatically when the clipboard prompt times out 
and closes.  

Turn Off Clipboard 
Monitoring for Now  

Disables the Watch Clipboard option. Watch Clipboard can be 
re-enabled directly from the TextAloud Tools menu, or from 
the Clipboard Options dialog.  

Always Ignore 
Clipboard Updates 
From  

Allows you to specify that future clipboard updates from the 
application that triggered the Clipboard Prompt will be 
ignored. The list of applications to ignore is available on the 
Clipboard Options dialog.  

 

 
Selecting An Action 



 
To select an action from the clipboard prompt, you can click do either of the following:  
 
1. Click one of the three action buttons at the bottom of the prompt. 
2. Select an action from the Action Dropdown list and click the "Perform" button.   
 
By default the action buttons displayed on the prompt are New, Append and Ignore.  The actions 
assigned to the New and Append buttons can be configured by right clicking either button, and choosing 
the action to assign to the button from the popup menu displayed. 
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  If you want to ignore clipboard updates from one or more specific applications, click the Show Details 

button when the prompt is displayed, and select the option to Always Ignore Clipboard Updates from the 
application.  

  The "Watch Clipboard" setting can be accessed directly from the Tools menu, as well as the popup 

menu displayed by right clicking the TextAloud tray icon.  

  You can assign a TextAloud Hotkey to the Watch Clipboard menu entry, and toggle clipboard watching 

on and off with the Hotkey. 
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Mouse Speak Prompt 
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The Mouse Speak Prompt is displayed when the option Watch Mouse is enabled, and you use your 
mouse to select text in any application.  When the prompt is displayed, you can select an action from a 
dropdown list of available actions, or click the Ignore button to ignore the text selection. 
 
Actions available from the Mouse Prompt 
 
The following actions may be selected from the Mouse Prompt: 
 
Add New Article - Use this action to add a new TextAloud article and load it with the current text 
selection. 
 
Insert Text At Top of Article - Inserts the selected text at the top of the current TextAloud article 
 
Insert Text At Current Cursor Position - Inserts the selected text at the current cursor position in the 
current TextAloud Article. 
 
Append Text to Bottom of Article - Appends the selected text to the bottom of the current TextAloud 
article. 
 
Speak Text - Speaks the currently selected text. 
 
Vocal Proofread - Opens the Vocal Proofread window, loads the window with the selected text, and 



begins proofreading. 
 

 
Configuring the Mouse Prompt 
 
The Mouse Prompt can be configured from the Mouse Options dialog, available under the TextAloud 
Tools menu.  Some configuration options may also be set by clicking the Show Details link on the prompt. 
 
The following configuration options are available when Show Details is clicked: 

Field  Description  

Display Prompt For  Specifies the number of seconds the mouse prompt will 
display before automatically closing.  

Set Last Action As 
Default Action  

When this option is selected, when an action is selected from 
the mouse prompt, that action becomes the default action.  

Perform Action 
Automatically On 
Timeout  

Specifies whether or not the Default Action should be 
performed automatically when the mouse prompt times out 
and closes.  

Turn Off Mouse 
Monitoring for Now  

Disables the Watch Mouse option. Watch Mouse can be re-
enabled directly from the TextAloud Tools menu, or from the 
Clipboard Options dialog.  

Always Ignore 
Mouse Messages 
From  

Allows you to specify that future mouse messages from the 
application that triggered the Mouse Prompt will be ignored. 
The list of applications to ignore is available on the Mouse 
Options dialog.  

 

 
Selecting An Action 
 
To select an action from the mouse prompt, you can click do either of the following:  
 
1. Click one of the three action buttons at the bottom of the prompt. 
2. Select an action from the Action Dropdown list and click the "Perform" button.   
 
By default the action buttons displayed on the prompt are New, Append and Ignore.  The actions 
assigned to the New and Append buttons can be configured by right clicking either button, and choosing 
the action to assign to the button from the popup menu displayed. 
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  If you want to ignore mouse messages from one or more specific applications, click the Show Details 

button when the prompt is displayed, and select the option to Always Ignore Mouse Messages from the 
application.  

  The "Watch Mouse" setting can be accessed directly from the Tools menu, as well as the popup menu 

displayed by right clicking the TextAloud tray icon. 
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Floating Toolbar 
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The Floating Toolbar provides access to some functions in the TextAloud main window.  Buttons on the 
toolbar are: 

Button  Description  

Speak All  Speak all articles currently loaded in the TextAloud window  

All To File  Speak all articles currently loaded in the TextAloud window 
to audio files.  

Pause/Resume  Used to pause and resume speaking.  

Stop  Used to stop speaking.  

Main  Hides the floating toolbar and displays the TextAloud main 
window.  

 

 
Configuring the Floating Toolbar 
 
To configure the Floating Toolbar, click TextAloud Options on the TextAloud Tools menu, and click the 
Miscellaneous tab.  The option labeled "Show Floating Toolbar" controls when the Floating Toolbar is 
displayed.  If set to "On Request Only", the toolbar is never displayed automatically.  You must first 
minimize the TextAloud main window, then right click the TextAloud tray icon, and click Show Toolbar in 
the popup menu.  To have TextAloud display the Floating Toolbar automatically, set the Show Floating 
Toolbar option to either "When Minimized", or "When Minimized and Speaking". 
 
Other options available on the Miscellaneous tab for configuring the Floating Toolbar include the toolbar 
button size, whether button captions should be displayed, and if the Floating Toolbar should be forced to 
remain on top of other windows. 
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Article Options 

 
The Article Options panel lets you set up options for assigning article titles, archiving articles and other 
display related options. 
 
The following fields are available in the Article Options panel 

Field  Description  

Article Title Option  The Article Title Option is a dropdown list that lets you 
configure how how article titles are generated. The following 
four selections are available: 

End on nearest word boundary 
Reads article text up to the number of characters specified 



by Maximum Title Length. This string is truncated to the 
nearest word boundary and assigned as the article title. 

End on first newline character 
Reads article text up to the first newline character for the 
title. If the title length exceeds the value specified in 
Maximum Title Length, the title is truncated to the nearest 
word boundary. 

Use first full sentence 
Reads article text up to the first sentence for the title. If the 
title length exceeds the value specified in Maximum Title 
Length, the title is truncated to the nearest word boundary. 

Use custom article title 
The text specified in the Custom Article Title field is used as 
the article title.  

Maximum Title Length  Used together with the Article Title Option to limit 
automatically generated article titles to a maximum length. 
The Maximum Article Title length field is disabled when the 
"Use custom article title" option is used.  

Use document name 
as article title when 
loading text from 
documents  

If this option is checked, the document name is used as the 
article title when articles are loaded via File -> Open. The 
directory path and file extension are not included in the title.  

Archive Deleted 
Articles  

When this option is checked, articles will be written to an 
archive whenever they are deleted. Deleted articles can be 
retrieved from the archive and restored as TextAloud 
articles.  

Delete articles from 
the archive older than  

Specifies that TextAloud should automatically delete articles 
from the archive older than the number of specified days.  

Limit number of 
articles loaded to 1  

Limits the number of articles that can be loaded into 
TextAloud at any time to a single article. Any time an article 
is added to TextAloud, the existing article is deleted.  

Smooth Scrolling  When this option is checked, any vertical scrolling in the 
article is smooth. Text in the display slides up and down 
smoothly, instead of jumping. Some users find word 
highlighting in TextAloud easier to follow when smooth 
scrolling is performed.  

Alternate Tab Shading 
by  

When this option is checked the percentage value specified 
is used to lighten/darken adjacent tabs in the TextAloud 
main window. This prevents the tabs from appearing to run 
together, making it easier to distinguish one tab from 
another.  
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Font Options 

 
The Font panel allows you to configure the fonts and colors used to display articles, as well as the fonts 
and colors used in the article tabs.  The following fields are available on the Font Options panel: 
 

Field  Description  

Font  A dropdown list that determines which font is being configured. 
Select "Article Text" to configure the article display font, and 
"Article Tabs" to configure the font used in article tabs.  

Font Name  The name of the font.  

Bold  If this option is checked, a bold font style will be used.  

Italic  If this option is checked, an italic font style will be used.  

Font Size  Specifies the height of the font in points.  

Script  Specifies the character set of the font.  

Foreground 
Text Color  

Click this button to assign a color to the font.  

Background 
Color  

Click this button to assign a background color.  
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When setting the background color for Article Tabs, there is an option on the Article Options panel to 
alternate shading between adjacent tabs.  If the shading option is used, the background color selected on 
this tab will appear slightly lighter (or darker) on alternating tabs. 
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Font Options (Vocal Proofreading) 

 
The Font panel allows you to configure the fonts and colors used in the Vocal Proofreader window.  The 
following fields are available on the Font Options panel: 
 

Field  Description  

Font Name  The name of the font.  

Bold  If this option is checked, a bold font style will be used.  

Italic  If this option is checked, an italic font style will be used.  

Font Size  Specifies the height of the font in points.  

Script  Specifies the character set of the font.  

Foreground Text Color  Click this button to assign a color to the font.  

Background Color  Click this button to assign a background color.  
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Highlighting Options 

 
Options on the Highlighting Options panel control how text displayed in TextAloud Articles is highlighted 
as text in the article is read aloud.  Highlighting options are grouped into three sections on the panel: 
Primary Highlighting, Secondary Highlighting, and Masking. 
 
Primary and Secondary Highlighting 
 
To configure highlighting, the first step is to select the checkbox labeled "Primary Highlighting Enabled", 
along with a unit of text you would like to highlight.  Primary Highlighting can be configured to highlight the 
current Word, Line, Sentence or Paragraph.  Bold, Italic, and Underline font styles may be applied to the 
highlighted text, along with foreground and background colors. 
 
Once Primary Highlighting is configured, you may optionally configure Secondary Highlighting as 
well.  Secondary Highlighting can only be enabled if Primary Highlighting is enabled.  Secondary 
highlighting allows you to apply highlighting to a section of text that contains the Primary Highlighting text 
unit.  For example, one highlighting style may be applied to the Current Word as Primary Highlighting, 
and another highlighting style may be applied the Current Paragraph as Secondary Highlighting. 
 
Masking 
 
Masking is basically the opposite of highlighting.  Primary and Secondary highlighting are used to draw 
your attention to the text currently being read.  The idea of masking is to have text that is not being read 
blend into the background color of the display.  So when masking is enabled, the mask is applied to any 
text that is not highlighted by Primary or Secondary highlighting.  The slider control to the right of the 
"Masking Enabled" checkbox lets you select the degree of masking to use.  If you position the slider 
control all the way to extreme left, any text not highlighted will be completely invisible. 
 
The sample text at the bottom of the Highlighting tab will give you an idea how your combined Primary 
Highlighting, Secondary Highlighting and Masking selections will display. 
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Miscellaneous Options 

 
The following fields are available on the Miscellaneous Options panel: 

Field  Description  

Show Floating 
Toolbar  

Controls display of the floating toolbar. 



On Request Only 
The Floating Toolbar is only displayed from the TextAloud icon 
in the system tray. Right click the icon and select "Show 
Toolbar". 

When Minimized 
The Floating Toolbar is displayed whenever TextAloud is 
minimized. The toolbar is also automatically hidden when the 
main window is redisplayed. 

When Minimized and Speaking 
The Floating Toolbar is displayed only when TextAloud is 
minimized and currently speaking.  

Floating Toolbar 
Button Size  

Allows you to choose Small, Medium or Large buttons in the 
Floating Toolbar.  

Show Floating 
Toolbar Button 
Captions  

Select this option to display captions on the Floating Toolbar 
buttons. You can also hover your mouse over any button on 
the toolbar to display a button hint.  

Floating Toolbar 
Always On Top  

Select this option to keep the Floating Toolbar on top of your 
other windows. This prevents other windows from hiding the 
toolbar.  

Show TextAloud 
on Windows 
Taskbar when 
minimized  

Use this option to control whether or not TextAloud appears on 
the windows Taskbar when minimized.  

Show TextAloud in 
System Tray when 
closed  

This setting controls the behavior of the "X" button in the 
TextAloud title bar. The default setting is to hide the window, 
and leave TextAloud running in your system tray. To exit the 
TextAloud application, you must select "Exit TextAloud" from 
the File Menu. 

If you uncheck this setting, clicking the "X" button will cause 
TextAloud to exit instead of minimizing to the system tray  

Start TextAloud on 
Windows Login  

Select this option if you want TextAloud to start automatically 
whenever you login to Windows.  

Show Splash 
Screen at Startup  

Uncheck this option to suppress the splash screen normally 
displayed by TextAloud during startup.  
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The standard Windows keyboard shortcut Alt+Tab to tab between windows only works for applications on 
the Windows Taskbar.  If you want to use this shortcut to find TextAloud when the TextAloud window is 
minimized, you should select the option 'Show TextAloud on Windows Taskbar when minimized'. 
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Voice Options 

 



The Voice Options panel is used for configuring voice assignment for new articles, the version(s) of SAPI 
used by TextAloud, and preferences for individual voices. 
 
Voice Assignment for New Articles 
 
The following fields are available for configuring voice assignment to new articles: 

Field  Description  

Voice 
Assignment 
Option  

Voice Assignment Option is a dropdown list containing the following 
selections: 

Default Voice 
If Default Voice is selected as the Voice Assignment Options, one 
voice is chosen as the default voice to be assigned to all TextAloud 
articles. The default voice is configured in the Voice Preferences 
section at the bottom of the panel. 

Random Voice for Default Language 
As articles are created in TextAloud, a random voice for the default 
language will be assigned to each article. Only voices that are 
enabled will be assigned to new articles. 

Round Robin for Default Language 
Voices for new articles are assigned sequentially based on the 
default language. Only voices that are enabled will be assigned to 
new articles.  

Default 
Language  

The language used when Random or Round Robin voice 
assignment is performed.  

Dialect  The dialect is used together with the Default Language when 
Random or Round Robin voice assignment is performed.  

 

 
The purpose of the Default Language and Dialect fields in the Voice Assignment section is to allow 
Random or Round Robin voice selection to be used when voices for multiple languages are installed.  By 
setting the Default Language and Dialect, Random and Round Robin voice assignments will always 
choose a voice for the selected language and dialect. 
 
The term 'Dialect' is used basically to mean any difference in voice accent based on region or 
geography.  For example, voices treat the United States, United Kingdom, and Australia as different 
dialects of English.  
 
Voice Preferences 
 
The following fields are available in the Voice Preferences section of the panel: 

Field  Description  

SAPI Version  Use this dropdown list to restrict which speech engines are 
loaded by TextAloud.  

Tree view  The tree view contains a list of Engines and Voices loaded into 
TextAloud.  



Slider Controls  Speed, Pitch and Volume slider controls are enabled if you 
select a voice from the tree view.  

 

 
Setting SAPI Version 
 
SAPI is Microsoft's Speech Application Interface, and is an interface for application programs like 
TextAloud to interact with speech engines.  There are currently two versions of SAPI available, SAPI4 
and SAPI5. Both interfaces are supported by TextAloud, but there are some differences in available / 
implemented features.  There are several features available in SAPI5 that are not supported in SAPI4, 
such as Voice Tags and Direct Encoding. 
 
In general you will want to leave the SAPI Version dropdown set to "Use Both", which causes TextAloud 
to load voice engines for both speech interfaces.  If you're having a problem with either SAPI4 or SAPI5 
on your system, changing the SAPI Version dropdown can sometimes be used to work around the 
problem. 
 
Setting Speed, Pitch and Volume 
 
All voices support Speed and Volume control.  Pitch support depends on the voice, several voices do not 
support Pitch control.  When Pitch control for a selected voice is not available, the Pitch slider will be 
replaced by a note stating that Pitch control is not available for the voice. 
 
Like Speed and Pitch, Volume is also a voice attribute.  The volume slider on this panel is useful for 
adjusting the volume of a voice relative to other voices.  If you're using several voices, and run into 
problems with the volume varying between voices, you can correct it for by adjusting voice volumes on 
this panel.  Note that adjusting voice volumes on this panel has no effect on your system audio volume. 
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System-wide hotkeys can be configured for changing both the Default Voice and the Default Language. 
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File Options 

 
The following fields are available on the File Options panel: 

Field  Description  

Audio File Format  Select an audio format from one of the available encoders on 
your machine. The most commonly used audio formats are 
MP3 and WMA.  

Bit / Sample Rate  This setting is used to determine the quality of audio files 
generated by TextAloud. The setting "Default for Voice" can be 
used to have TextAloud automatically choose a Bit/Sample 
rate setting based on the type of audio produced by the voice.  

Silence at end of 
Audio File  

Specifies a period of silent time to include at the end of audio 
files. The silent time is specified in seconds.  

Audio Output 
Directory  

The directory where audio files are written.  



Confirm Output 
Directory when 
writing Audio Files  

Specifies whether or not TextAloud will prompt you to confirm 
the Audio Output Directory before writing audio files. The 
confirmation prompt will allow you to use the default Audio 
Output Directory or change it.  

Prompt Before 
Overwriting Audio 
Files  

Specifies whether or not TextAloud will prompt you before 
overwriting existing audio files. If this option is not selected, 
TextAloud will always overwrite existing audio files without 
prompting you.  

Add Audio to 
iTunes Playlist  

Specifies whether audio files created by TextAloud will be 
automatically added to iTunes in the specified Playlist. This 
option is available only if iTunes is installed, and the Audio File 
Format is an MP3 format.  

Split Audio Files 
Every  

Specified whether TextAloud should automatically split audio 
files to limit the audio in each file to the number of specified 
minutes.  

 

 
The contents of the Audio File Format dropdown list are machine dependent.  The list includes encoders 
available on your machine, and different machines may have different encoders installed. 
 
A typical list of installed encoders includes: 

Encoder  Description  

IMA ADPCM  An ADPCM algorithm developed by Interactive Media 
Association (IMA). ADPCM is a variation of PCM audio, and 
produces wav files. ADPCM use an algorithm to predict 
samples based on previous samples, saving the differences 
between predictions and actual values, and in this way 
produces smaller wav files.  

MS-ADPCM  Microsoft's variation of ADPCM (see IMA ADPCM above).  

CCITT A-Law  An algorithm developed by an international committee in 
Geneva to compress 16 bit PCM audio to 8 bit.  

CCITT u-Law  Like A-Law (see above), u-Law also compresses 16 bit PCM 
audio to 8 bit. The actual differences between A-Law and u-Law 
are very technical.  

GSM 6.10  A speech compression algorithm developed for use on digital 
cellular networks. GSM stands for Global System for Mobile 
communications.  

DSP Group 
TrueSpeech(TM)  

An encoder developed by the DSP Group  

PCM  Pulse Code Modulation (PCM) is a digital representation of 
analog data. PCM wav files are not compressed, and will 
typically be much larger than other formats which use some 
compression technique.  

Windows Media 
Audio(WMA)  

An audio compression technology developed by Microsoft.  

Lame MP3  Lame MP3 encoder.  

 

 
If you have defined any Custom Encoders, the Custom Encoder captions will be available as Audio 
Formats.  If you select a Custom Encoder as the Audio Format, the Bit/Sample Rate drop down list will be 



disabled.  See the Custom Encoders tab for details. 
 
Choosing a Bit / Sample Rate 
 
You will notice that different combinations of Bit Rate and Sample Rate effect the quality of your audio 
files.  A general rule is to choose a Bit Rate or Sample Rate that gives you the best quality, but try to keep 
the Bit Rate as small as possible.  Smaller Bit Rates equate to smaller audio files and faster encoding 
time. 
 
When choosing a sample rate it is important to remember that high quality digital speech can be 
produced at much smaller sample rates than digital music. 
 
If you're planning to copy audio files to a hand-held device (like an MP3 Player), you may also need to 
check if your device requires a particular audio format.  Some players, designed for digital music, only 
support sample rates in the 44kHz range, and may also require Stereo instead of Mono audio files. 
 
Encoding in Stereo will significantly increase your audio file sizes and encoding times.  It is best to use 
stereo encoding only if required by the portable device you're using. 
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  If you are not sure which Audio Format to use, we recommend using either an MP3 or WMA format.  

  If you are not sure which Bit / Sample rate to use, try using the "Default For Voice" selection.  

  If you notice that audio at the very end of your audio files is being clipped, try using the 'Silence at end 

of Audio File' option to add a few seconds to the end of your files. 
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Custom Encoders 

 
The Audio File Formats dropdown list on the File Options panel is typically loaded with audio codecs that 
are 'registered' on your system.   The Windows multimedia system allows codecs to be registered and 
made available to audio applications such as TextAloud. 
 
Custom Encoders is a TextAloud feature that allows you use audio encoders that are not registered in the 
Windows multimedia system.  If you have an audio encoder that runs as a standalone program, 
TextAloud can use the encoder if you configure it as a Custom Encoder. 
 
When you create a Custom Encoder, you will assign a unique name that identifies the encoder.  This 
name will then appear in the Audio File Formats dropdown list, on the File Options panel.  From then on, 
you use the Custom Encoder in TextAloud just as using any other audio file format.  If a Custom Encoder 
is specified as the Audio File Format, TextAloud will run the encoder, using the command line specified, 
and pass wav data directly from a speech engine to the encoder. 
 
In order for an encoder program to be set up as a TextAloud Custom Encoder, the program must meet 
the following criteria: 

  The program must run from the command line, either by running the program directly, or running from a 

.bat file or script.  



  The program should use command line arguments for specifying encoding options such as Bit Rate 

and Sample Rate.  

  The command line should also indicate the directory / filename where the encoder should write its 

output.  

  The program must be able to receive WAV input from STDIN.  STDIN is a standard way of streaming 

input data to a program.  

  No user interaction with the encoder is possible while TextAloud is running the encoder.  The encoder 

cannot display any prompts; all user options need to be passed as command line arguments.  

  The program should run 'silently'.  Any error messages, progress messages, etc. should be 

suppressed. 
 
You will need to check the documentation for your encoder program to verify that it can configured like 
this. 
 

 
Adding and Editing Custom Encoders 
 
The following fields are available on the Add/Edit panel: 

Field  Description  

Custom 
Encoder Name  

A name that uniquely identifies the Custom Encoder. This name 
will appear in the Audio File Format dropdown list, on the File 
Options panel.  

Sample Rate  Specifies the Sample Rate that the encoder expects in the input 
wav data. TextAloud will resample wav data if necessary.  

Number of 
channels  

The number of audio channels that the encoder expects in the 
input wav data. TextAloud will adjust the wav input stream to 1 or 2 
channels, depending on this setting.  

Command Line  The command line to run the encoder.  

 

 
Replaceable Parameters 
 
Normally when audio files are generated from TextAloud, TextAloud will write audio files to a default 
directory, and generate file names based on the article title.  Since this information needs to be passed as 
command line arguments to the encoder, there are replaceable parameters you can use for the directory 
and file name.  TextAloud will replace these parameters before launching the encoder. 
 
Replaceable parameters you can use are: 

Replaceable 
Parameter  

Description  

%AudioDirectory%  The default audio file directory specified on the File 
Options panel.  

%Title%  The Title to use as the file name.  

 

 
Using replaceable parameters, instead of hard coding a filename in your command line string, you can 
specify a filename like this: 
 



%AudioDirectory%\%Title%.mp3 
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Audio File Tags 

 
Use the Audio File Tags panel to configure audio tags written to your audio files.  Tag information is then 
displayed in player software you run on your PC, such as Windows Media Player, as well as on your 
portable audio player. 
 
The "Lyrics" tag for an audio file is normally used to store the lyrics for a song.  If you select the checkbox 
"Save Text as Audio File Lyrics", TextAloud will write the text for an audio file into the file's Lyrics 
tag.  You can then display the text for an audio file on your portable player as you listen to it, provided 
your player supports the Lyrics tag. 
 
Most player software will recognize and display some subset of tags available on the Audio File Tags 
panel.  There may be tags on this panel that do not display on your player.  If this happens, you can use 
one of the other tags, such as the Comments tag, to store the data. 
 
Replaceable Parameters 
 
The Audio File Tags panel supports several replaceable parameters.  TextAloud determines the values 
for the following parameters and substitutes them as the tags are written: 

Replaceable 
Parameter  

Description  

%AudioFileName%  The name of the audio file, including the file extension. The 
name does not include the directory path.  

%Title%  The article title associated with the file.  

%Voice%  The name of the voice used to speak the text.  

%ShortVoice%  Short version of %Voice%. The substituted text excludes 
Vendor and Language information associated with the voice.  

%VoiceSpeed%  The speed setting for the voice used to speak the text.  

%VoicePitch%  The pitch setting for the voice used to speak the text.  

%DateTime%  The date and time the audio file was written.  

%Date%  The date the audio file was written  

%Time%  The time the audio file was written  

%Year%  The current year. Mainly exists for use with the Year tag.  

%EncoderName%  The name of the encoder used to write the audio file. The 
encoder name is the current Audio File Format setting.  

%QualitySettings%  The quality settings used to write the audio file. The Bit / 
Sample Rate setting from the File Options panel is stored in 
this tag.  

%VoiceLanguage%  The language for the voice used to generate the audio file.  
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Background Audio 

 
The Background Audio panel allows you to specify the name of an audio file that will be merged with 
Text-To-Speech output.  TextAloud will write a single audio file, containing both spoken text and 
background audio.  This can be used to specify a music file that plays in the background of your spoken 
text. 
 
The background audio file will loop.  So if you specify a music file that is not as long as the audio for your 
spoken text, the music file will restart each time it finishes. 
 
The following fields are available on the Background Audio panel: 

Field  Description  

Play Background 
Audio  

Use this checkbox to enable or disable the background audio 
feature. Background audio is created for your TextAloud audio 
files when this option is checked.  

Background 
Audio  

The name of an existing MP3, WMA, or WAV file to use as 
background audio.  

Background 
Audio Volume  

Use this slider control to adjust the volume of the background 
audio relative to the spoken text volume.  

 

 
Use the Test button on the Background Audio panel to help with getting the right background audio 
volume.  You will want to set the background audio to a volume where the background audio is audible, 
but you can still hear the spoken text clearly.  The test will speak some sample text, using the default 
voice, and continue looping until you click Stop.  Adjust the slider control while the test is in progress until 
you find an appropriate volume setting. 
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Hotkey Setup - Main Window 

 
The Hotkey Setup window allows you to associate system-wide hotkeys with TextAloud actions. 
 
Each hotkey is associated with a TextAloud Action, along with one or more options.  Hotkeys can be 
configured for the following actions: 

  Import Text:  Copies text from an external application to a TextAloud article.  

  Read Text Aloud: Speak text from an external application aloud.  

  Vocal Proofread: Speak text from an external application aloud, using the Vocal Proofread window.  

  Change Default Voice: Changes the Default Voice setting on your Voice Options panel.  

  Change Default Language: Changes the Default Language and Default Dialect settings on your Voice 

Options panel.  

  Pause/Resume: Pauses or Resumes speaking when speaking text aloud.  



  Stop: Stop speaking and return TextAloud to idle state. 
 
Hotkeys defined on the Hotkey Setup Dialog have the following properties: 

Property  Description  

Enabled 
Checkbox  

Indicates whether or not the hotkey is currently enabled.  

Action  One of several predefined actions associated with the hotkey, and is 
the action that will be performed when the hotkey keystroke sequence 
is pressed. The action itself is not displayed in the main window. 
Instead, a user specified Caption is associated with each hotkey 
definition, and is displayed in the main window.  

Caption  A name that identifies the hotkey. The name is important because 
multiple hotkeys can be defined to perform the same action. For 
example, multiple hotkeys can be defined perform the action "Read 
Text Aloud", where each hotkey uses a different voice.  

Hotkey  The hotkey keystroke sequence.  

Hotkey 
Options  

Options associated with the hotkey that are specific to the hotkey 
action. For example, several hotkey actions allow you to specify a 
TextAloud Voice associated with the action.  

 

 
To create a new hotkey:  

  Click Edit -> New Hotkey on the menu, or click the New Hotkey button on the toolbar.  

  Fill in the Add Hokey dialog. 
 
To edit an existing hotkey  

  Select an existing hotkey to modify.  

  Click Edit -> Edit Hotkey on the menu, or click the Edit Hotkey button on the toolbar.  

  Update the Edit Hotkey dialog with your changes.  
 
To delete an existing hotkey  

  Select an existing hotkey to delete  

  Click Edit -> Delete Hotkey on the menu, or click the Delete Hotkey button on the toolbar. 
 
To change whether or not a hotkey is enabled:  

  Toggle the checkbox for the row.  Or select the row and tap the spacebar. 
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Add/Edit Hotkey 

 
The following fields are available in the dialog to Add/Edit Hotkeys: 

Field  Description  



Action  One of several predefined actions associated with the hotkey. This is 
the action that will be performed when the hotkey keystroke sequence 
is pressed.  

Caption  A user specified name associated with the hotkey.  

Hotkey  The actual hotkey keystroke sequence. To enter the keystroke 
sequence, tab into the Hotkey field, and press the keystrokes you 
would like to assign.  

Hotkey 
Enabled  

Checkbox that indicates whether or not the hotkey is currently 
enabled. You can temporarily disable the hotkey by unchecking this 
field.  

Hotkey 
Options  

One or more dropdown lists that allow you to assign options to the 
hotkey. The options available to be assigned to a hotkey are action 
specific. See below for a description of hotkey actions and associated 
options.  

 

 
Hotkey Action Descriptions 
 
Import Text:  Copies text specified by the Text Source into a TextAloud article 
Hotkey Options: Text Source, Copy Text To, Voice 
 
Read Text Aloud: Speaks text specified by the Text Source aloud, using the specified Voice. 
Hotkey Options: Text Source, Voice 
 
Vocal Proofread: Speaks text specified by the Text Source aloud, using the Vocal Proofread window. 
Hotkey Options: Text Source, Voice 
 
Change Default Voice: Changes the Default Voice setting on your Voice Options panel. 
Hotkey Options: Default Voice 
 
Change Default Language: Changes the Default Language and Default Dialect settings on your Voice 
Options panel. 
Hotkey Options: Default Language, Default Dialect 
 
Pause/Resume: Pauses or resumes speaking when speaking text aloud. 
Hotkey Options: None 
 
Stop: Stops speaking and returns TextAloud to an idle state. 
Hotkey Options: None 
 

 
Hotkey Option Descriptions 
 
Text Source: Specifies the text source for a hotkey.  Selections include "Highlighted Text" and "Windows 
Clipboard".  The Text Source option allows you to pick whether a hotkey selects highlighted text from an 
application, or processes text already on the Windows Clipboard. 
 
Copy Text To: Used with the Import Text action to specify where text should be copied.  Selections 
include "New Article", "Top of Current Article", and "Bottom of Current Article". 
 
Voice: Allows you to assign a TextAloud voice to a hotkey action. The selection "Use TextAloud Voice" 
can be used to allow TextAloud to pick a voice automatically, based on your Voice Options configuration. 



 
Default Voice: This option is only available with the Change Default Voice hotkey, and specifies the new 
default voice when the hotkey is pressed. 
 
Default Language: This option is only available with the Change Default Language hotkey, and specifies 
the new default language when the hotkey is pressed. 
 
Default Dialect: This option is only available with the Change Default Language hotkey, and specifies the 
new default dialect when the hotkey is pressed. 
 
Missing image: tip.bmp Tip 
There some keystroke sequences that do not work as hotkeys.  Use the Test Hokey button on this 
window to verify that the keystroke sequence you're trying to assign is recognized by TextAloud as a valid 
hotkey. 
 
Missing image: tdoc4.bmp Notes 
When defining hotkeys, be sure to use key combinations that are not already used by Windows or any 
applications you use.  For example, do not assign Ctrl+C as a hotkey, since this key combination is used 
by Windows for writing to the clipboard. 
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Clipboard Options 

 
TextAloud can be configured to watch your Windows Clipboard for changes, and perform actions on the 
clipboard text.  Clipboard text can be inserted into existing articles, added as new articles, spoken aloud, 
or spoken using the Vocal Proofreading window.  The Clipboard Options panel is used to configure the 
clipboard watching feature. 
 
The following fields are available on the Clipboard Options panel: 

Field  Description  

Watch Clipboard  This option determines whether or not TextAloud will watch 
the Windows Clipboard for updates. All options on this panel 
are effective only if Watch Clipboard is checked.  

Ignore Clipboard 
Text less than  

Sets the minimum amount of text on the Windows Clipboard 
that TextAloud will recognize. Set this to a value high enough 
so that TextAloud will ignore routine copy and paste 
operations between windows.  

Ignore Clipboard 
Updates if text has 
not changed  

Select this checkbox to prevent TextAloud from acting on the 
same text multiple times. TextAloud will recognize clipboard 
updates only if the clipboard text actually changes.  

Prompt to copy text 
from clipboard  

Select this option to have TextAloud prompt you before 
acting on text from the Windows Clipboard. If this option is 
not selected, TextAloud will retrieve text from the clipboard 
and perform the Default Action without prompting you.  

Display Prompt for  Specifies the number of seconds the clipboard prompt will 
display before automatically closing.  



Default Action  Specifies the action that will be selected by default in the 
clipboard prompt. If the prompt dialog is disabled, this action 
will be performed automatically on each clipboard update.  

Perform Action 
Automatically on 
Timeout  

Specifies whether or not the Default Action should be 
performed automatically when the clipboard prompt times out 
and closes.  

Set Last Action as 
Default Action  

When this option is selected, any time an action is selected 
from the clipboard prompt, that action becomes the default 
action.  

 

 
At the bottom of the Clipboard Options panel, there is a list labeled "Ignore clipboard updates from these 
applications:".  Applications are added to this list from the Clipboard Prompt; when the Clipboard Prompt 
is displayed, an option is available on the prompt to ignore clipboard updates from the application that 
triggered the prompt. 
 
Use the "Remove From List" button on this panel if you decide later that you want to receive clipboard 
updates from an application that was previously ignored. 
 
Missing image: tip.bmpTips  

  Occasionally applications will send Windows Clipboard notifications when in fact, the clipboard was not 

updated.  You may also see this happen if you are using Clipboard Manager software.  Try using the 
option "Ignore Clipboard Updates if text has not changed" to work around this problem.  

  The "Watch Clipboard" setting can be accessed directly from the Tools menu, as well as the popup 

menu displayed by right clicking the TextAloud tray icon.  

  You can assign a TextAloud Hotkey to the Watch Clipboard menu entry, and toggle clipboard watching 

on and off with the Hotkey. 
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Mouse Speak Options 

 
TextAloud can be configured to watch your mouse when highlighting text in applications.  When you 
make a text selection using your mouse, TextAloud can recognize when you release the left mouse 
button and perform actions on the selected text.  Selected text can be inserted into existing articles, 
added as new articles, spoken aloud, or spoken using the Vocal Proofreading window.  The Mouse 
Speak Options panel is used to configure the mouse watching feature. 
 
The following fields are available on the Mouse Speak Options panel: 

Field  Description  

Watch Mouse  This option determines whether or not TextAloud will watch 
your mouse for text selections. All options on this panel are 
effective only if Watch Mouse is checked.  

Ignore Highlighted 
Text less than  

Sets the minimum text selection length that TextAloud will 
recognize. Set this to a value high enough so that TextAloud 



will ignore text you routinely highlight for other purposes, such 
as copy and paste between applications.  

Ignore Highlighted 
Text if text has not 
changed  

Select this checkbox to prevent TextAloud from acting on the 
same text selection multiple times. TextAloud will recognize 
text selections only if the current text selection is different 
than the previous text selection.  

Prompt to copy 
highlighted text  

Select this option to have TextAloud prompt you before acting 
on highlighted text. If this option is not selected, TextAloud 
will retrieve highlighted text and perform the Default Action 
without prompting you.  

Display Prompt for  Specifies the number of seconds the mouse prompt will 
display before automatically closing.  

Default Action  Specifies the action that will be selected by default in the 
mouse prompt. If the prompt dialog is disabled, this action will 
be performed automatically each time you select text with 
your mouse.  

Perform Action 
Automatically on 
Timeout  

Specifies whether or not the Default Action should be 
performed automatically when the mouse prompt times out 
and closes.  

Set Last Action as 
Default Action  

When this option is selected, any time an action is selected 
from the mouse prompt, that action becomes the default 
action.  

 

 
At the bottom of the Mouse Speak Options panel, there is a list labeled "Ignore highlighted text from these 
applications:".  Applications are added to this list from the Mouse Speak Prompt; when the Mouse Speak 
Prompt is displayed, an option is available on the prompt to ignore text selections from the application 
that triggered the prompt. 
 
Use the "Remove From List" button on this panel if you decide later that you want to highlighted text 
notifications from an application that was previously ignored. 
 
Missing image: tip.bmpTips  

  The "Watch Mouse" setting can be accessed directly from the Tools menu, as well as the popup menu 

displayed by right clicking the TextAloud tray icon.  

  You can assign a TextAloud Hotkey to the Watch Mouse menu entry, and toggle mouse watching on 

and off with the Hotkey. 
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Character Speaking and Filtering - Main Window 

 
The Character Speaking and Filtering dialog lets you configure special handling for individual characters 
that appear in the text.  The following options can be specified for individual characters or sets of 
characters: 

  Filter the specified characters(s) from the text  

  Pronounce the characters  



  Trigger a sound file to be played  

  Cause speech to pause for a specified interval. 
 
The option to speak characters aloud or trigger a sound file to be played is typically used during 
proofreading.  Using the option to speak characters, you can have punctuation in the text pronounced as 
the characters are processed.  For example, a comma will be actually be pronounced as 
"comma".  Alternatively, groups of characters may have different sound files played as the characters are 
encountered. 
 
Automatic Text Insertions provides several 'hook' points for inserting pauses, including between 
sentences and between paragraphs.  The Automatic Text Insertions dialog should normally be used for 
inserting these types of pauses.  The Character Speaking and Filtering dialog extends this automatic 
pause capability by allowing you to specify other characters where you would like pauses to be 
inserted.  For example, if you would like to pause at every semi-colon, the Character Speaking and 
Filtering dialog is the place to configure that. 
 
One of the attributes associated with an entry is a Profile, which allows you fine tune when the Character 
Speaking and Filtering entry will be applied.  In order for an entry to be applied when speaking, the 
following two conditions must hold: 
 
1. The Character Speaking and Filtering entry must be active 
2. The Profile assigned to the entry must match the profile in use when text is spoken. 
 
Character Speaking and Filtering entries have the following properties: 

Property  Description  

Enabled 
Checkbox  

Indicates whether or not the entry is currently enabled  

Profile  Identifies which speaking profile the entry is associated with. If 
Profile is set to '*' (asterisk), the entry is associated with all 
speaking profiles.  

Character 
Option  

Identifies how the characters associated with the entry will be 
handled. Options include Filter Character, Speak Character, and 
Play Sound.  

Characters  Identifies one or more characters associated with the entry.  

 

 
To create a new character speaking and filtering entry:  

  Click Edit -> Add on the menu, or click the Add button on the toolbar.  

  Fill in the Add Character Speaking and Filtering dialog. 
 
To edit an existing character speaking and filtering entry  

  Select an existing automatic text insertion to modify.  

  Click Edit -> Edit on the menu, or click the Edit button on the toolbar.  

  Update the Edit Character Speaking and Filtering dialog with your changes.  
 
Note that the Profile for an entry cannot be edited.  To change the profile for a character speaking and 
filtering entry, you must delete the entry and recreate it. 
 
To delete an existing character speaking and filtering entry  



  Select an entry to delete  

  Click Edit -> Delete on the menu, or click the Delete button on the toolbar. 
 
To change whether or not an entry is enabled:  

  Toggle the checkbox for the row.  Or select the row and tap the spacebar. 
 
Missing image: tdoc4.bmp Related Topics 
Add/Edit Character Speaking and Filtering 
Automatic Text Insertions  
 

 

Add/Edit Character Speaking and Filtering 

 
The following fields are available in the dialog to Add/Edit Character Speaking and Filtering entries: 

Field  Description  

Profile  The TextAloud speaking profile assigned to the entry. Either 
select "All Profiles" to make the entry active for all profiles, or 
select a specific profile.  

Option  Select Filter Character, Speak Character, Play Sound or Pause  

Enabled  Specifies whether or not the entry is currently enabled  

Characters  Specify one or more characters to associate with the entry.  

Sound File  This field is enabled only if the Option for the entry is 'Play Sound'. 
The sound file must specify an existing MP3, WMA or WAV file.  
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Pauses and Text Insertions - Main Window 

 
The Automatic Text Insertions dialog allows you to configure various text strings to be inserted in spoken 
text at predefined text insertion points.  An example of a frequently used Automatic Text Insertion is the 
pause tag, often placed at 'Between Sentence' and/or 'Between Paragraph' insertion points. 
 
In addition to pauses, you can also define text insertions for audio clips, as well as free form text. 
 
One of the attributes associated with an Automatic Text Insertion is a Profile, which allows you fine tune 
when the text insertion will be applied.  In order for an Automatic Text Insertion to be used when 
speaking, the following two conditions must hold: 
 
1. The Automatic Text Insertion entry must be active 
2. The Profile assigned to the insertion must match the profile in use when text is spoken. 
 
Automatic Text Insertions have the following properties: 

Property  Description  



Enabled 
Checkbox  

Indicates whether or not the text insertion is currently enabled.  

Profile  Identifies which speaking profile the insertion is associated with. If 
Profile is set to '*' (asterisk), the text insertion is associated with all 
speaking profiles.  

Insertion Type  Identifies whether the text insertion is a pause tag, audio clip, or 
free form text.  

Insertion Point  Identifies places in the text where insertions will occur.  

Text To Insert  The actual text that will be inserted at each insertion point.  

 

 
To create a new automatic text insertion:  

  Click Edit -> Add on the menu, or click the Add button on the toolbar.  

  Fill in the Add Automatic Text Insertion dialog. 
 
To edit an existing automatic text insertion  

  Select an existing automatic text insertion to modify.  

  Click Edit -> Edit on the menu, or click the Edit button on the toolbar.  

  Update the Edit Automatic Text Insertion dialog with your changes.  
 
Note that the Profile for an Automatic Text Insertion cannot be edited.  To change the profile for an 
insertion, you must delete the entry and recreate it. 
 
To delete an existing automatic text insertion  

  Select an existing automatic text insertion to delete  

  Click Edit -> Delete on the menu, or click the Delete button on the toolbar. 
 
To change whether or not an automatic text insertion is enabled:  

  Toggle the checkbox for the row.  Or select the row and tap the spacebar. 
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Add/Edit Automatic Text Insertion 

 
The following fields are available in the dialog to Add/Edit Automatic Text Insertions: 

Field  Description  

Profile  The TextAloud speaking profile assigned to the text insertion. Either 
select "All Profiles" to make the text insertion active for all profiles, 
or select a specific profile.  

Type of 
Insertion  

Select Insert Pause, Insert Audio Clip, or Insert Text  

Insert At  Specifies where in the text the insertions will occur.  

Enabled  Specifies whether or not the text insertion entry is currently enabled.  



 

 
The remaining field displayed on the Add/Edit dialog depends on the type of insertion. 

For Insertion 
Type  

Enter this text  

Insert Pause  The number of seconds you would like to pause.  

Insert Audio 
Clip  

The name of an existing MP3, WMA, or WAV file you would like to 
embed in the text. Use the Browse button to locate valid sound 
files.  

Insert Text:  Free form text. You can enter any text you want, including 
replaceable parameters. See Tip below.  

 

 
Missing image: tip.bmp Tip 
When the "Insert Text" insertion type is used, the free form text may contain replaceable parameters.  For 
example, the current article title can be spoken using the replaceable parameter %Title%. 
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Automatic Text Insertion Replaceable Parameters 

 
For Automatic Text Insertions with Insertion Type set to "Insert Text", the following replaceable 
parameters may be used in the free form text string. 

Replaceable 
Parameter  

Description  

%Title%  The article title for the article being spoken. This parameter is 
ignored when speaking non-article text.  

%Voice%  The name of the voice that is currently speaking. When speaking 
articles, this will be the voice assigned to the article that is 
currently being spoken.  

%Time%  The current time.  

%DateTime%  The current date and time.  
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Automatic Actions - Main Window 

 
The Automatic Actions dialog allows you hook actions to activities that occur in TextAloud.  A typical 
example of TextAloud activity is a visual or audio notification that an article has been imported into 



TextAloud. 
 
Events defined in Event Setup have the following properties: 

Property  Description  

Enabled Checkbox  Indicates whether or not the automatic action is currently 
enabled.  

Caption  A name that uniquely identifies the automatic action.  

TextAloud Activity  The TextAloud activity that will trigger the automatic action.  

Automatic Action  An action that should be triggered whenever the specified 
TextAloud activity occurs.  

 

 
Automatic actions can be associated with the following list of TextAloud activities: 
 
Text imported to TextAloud 
Display TextAloud Article 
Before speaking article aloud 
After speaking article aloud 
Before speaking article to audio file 
After speaking article to audio file 
Before speaking all articles aloud 
After speaking all articles aloud 
Before speaking all articles to file 
After speaking all articles to file 
Before speaking non-article text aloud 
After speaking non-article text aloud 
Before batch file conversion 
After batch file conversion 
Clipboard Monitor Enabled 
Clipboard Monitor Disabled 
Article Deleted 
Before speaking article 
After speaking article 
 
Each trigger has one or more actions that may be assigned to it.  An Audio/Visual Notification action is 
available for all triggers, but other actions are available based on the trigger.  Multiple events can be 
assigned to a single trigger, so it is possible for a single event trigger to be associated with multiple Event 
Actions. 
 
Available automatic actions include: 

Automatic Action  Available for these TextAloud activities  

Visual/Audio Notification  All TextAloud activities  

Delete Article  After an article has finished speaking  

Speak Article  After a new article has been imported to TextAloud  

Open Audio Folder  After an audio file has been created  

 

 
To create a new automatic action:  



  On the Automatic Actions window, click Edit -> Add Action from the menu, or click the Add Action 

button on the toolbar  

  You will be prompted for a TextAloud Activity and an Automatic Action. Click OK to continue.  

  An options screen will then be displayed, allowing you to enter a Caption, and specify if the if the 

Automatic Action is active.  If you are configuring an Audio/Visual Notification Event Action, the 
Notification Event Options dialog will be displayed.  
 
To edit an existing automatic action:  

  On the Automatic Actions window, select the entry you would like to edit.  

  Click Edit -> Edit Action from the menu, or click the Edit Action button on the toolbar.  

  If the automatic action is an Audio/Visual Notification, the Notification Event Options dialog will be 

displayed.  Otherwise, you will be prompted to enter a new caption for the Automatic Action, as well as 
enable or disable the automatic action. 
 
Note that the TextAloud Activity and Automatic Action fields cannot be edited.  In order to change either 
of these fields, you must delete the automatic action and recreate it. 
 
To delete an existing automatic action:  

  On the Automatic Actions window, select the entry you would like to delete.  

  Click Edit -> Delete Action from the menu, or click the Delete Action button on the toolbar. 
 
To disable or enable an automatic action  

  Toggle the checkbox for the row.  Or select the row and tap the spacebar. 
 
Missing image: tdoc4.bmp Related Topics 
Notification Event Options  
 

 

Notification Options 

 
The Notification Options dialog is displayed when adding or editing an automatic action with the 
Automatic Action set to "Audio/Visual Notification".  The dialog allows you to configure the notification. 
 
At the top of the Notification Options dialog, you can specify a name for the notification action, as well as 
specify whether or not the automatic action is active. 
 
The dialog has separate sections for visual notifications and audio notifications; one or both can be 
specified. 
 
To configure a Display Notification:  

  The Automatic Action Enabled checkbox should be checked  

  The Display Event Notification above System Tray checkbox should be checked. 
 
You can optionally specify that the notification should be displayed only when TextAloud is 
minimized.  Use the Display Text field to configure the notification text. 
 
To configure an Audio Notification:  

  The Automatic Action Enabled checkbox should be checked.  



  From the dropdown list, select the type of audio notification you would like to hear.  Options include 

playing a default system sound, playing a sound file, and speaking text.  

  The checkbox to the left of the dropdown should be checked. 
 
Depending on the type of audio notification selected, the following options are available: 

Audio Notification  Options  

Default System Sound  None  

Play Sound File  A filename specifying an existing mp3, wma or wav file.  

Speak Text  A voice used to speak the notification, and the notification 
text  
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Custom Document Imports - Main Window 

 
Custom Imports are used to add TextAloud document support for file extensions that TextAloud does not 
recognize.  Custom Imports make use of programs installed on your machine, external to TextAloud, that 
perform the job of converting documents for a given file format / file extension to text files.  When a 
Custom Import is performed, the external program is started from a command line and passed the name 
of a document to convert, along with the name of a text file to create.  TextAloud then processes the 
output file created by the converter and deletes it. 
 
The following requirements must be met in order to create a Custom Import for a given file extension:  
1. You must have a converter program installed on your machine that can convert documents with the 
specified file extension to text files. 
2. The converter program must be able to run from a command line prompt, accepting input and output 
filenames on the command line. 
 
A Custom Import simply consists of a file extension, a brief description (displayed in the File Open dialog) 
and a command line.  The command line contains a string to run the external conversion program, see 
New Custom Import for help with setting up the command line.  
 
To create a new Custom Document Import:  

  Click Edit -> New Import on the menu, or click the New Import button on the toolbar.  

  Fill in the New Custom Import dialog. 
 
To edit an existing Custom Document Import  

  Select an existing Custom Import to modify  

  Click Edit -> Edit Import on the menu, or click the Edit Import button on the toolbar  

  Update the Edit Custom Import dialog with your changes. 
 
To delete an existing Custom Document Import  

  Select an existing Custom Import to delete  

  Click Edit -> Delete Import on the menu, or click the Edit  
 



 

Add/Edit Custom Import 

 
The following fields are available on the dialog to Add and Edit Custom Imports: 

Field  Description  

File Extension  The file extension for this custom import. When editing an import, 
the file extension field is read-only; to change a file extension you 
must delete the custom import and add it again.  

Brief 
Description  

A short description that indicates the type of files to be processed 
by the import, for example, "Text Files". The Brief Description will 
appear in TextAloud File Open dialogs in the File Type dropdown 
list.  

Command Line  The command line to run when a file for this file extension is 
imported to TextAloud. Details on setting up the command line are 
described below.  

 

 
Command Line Requirements 
 
In order for the Custom Import to work, the command line should specify the name of the converter 
program to run.  The full path for the program should be specified, unless you are sure the program is in 
your system path.  If you are not sure about this, just specify the full path.  File Input and File Output are 
handled as follows: 
 
1. The command line must use the string %InputFile% as a placeholder for the actual file to be converted. 
2. The command line must use the string %OutputFile% as a placeholder for the name of a text file to be 
created.  
 
When the Custom Import is performed, TextAloud will replace the placeholders %InputFile% and 
%OutputFile% with actual file names and run the converter.  Note that the output file created by the 
converter must be a text file.  The text may be plain ASCII, UTF8, or UTF16LE. 
 

 
Example 
 
The following example will set up a custom import for loading Braille files (.brf files) into TextAloud 
articles.  The example makes use of a utility called NFBTRANS, a utility that converts Braille files to text, 

available from the National Federation of the Blind (http://www.nfb.org/nfb/nfbtrans.asp). 

 
The New Custom Import dialog should be created like this: 
 
File Extension: .brf  
By specifying .brf as the file extension, the custom import is now associated with .brf Braille files. 
 
Brief Description: Braille Files 
The Brief Description associated with the Custom Import appears in TextAloud File Open dialogs.  The 
File Type field can be set to "Braille files" to display only .brf files in the File Open dialog. 
 
Command Line: c:\MyUtilities\nfbtrans.exe %InputFile% > %OutputFile% 
nfbtrans.exe is the name of the file converter program.  A full path to the program is specified in this 



example, and is required unless nfbtrans.exe is in the system path.  %InputFile% is the placeholder in the 
command line string which will be replaced with an actual file name when the Custom Import runs.  Also 
note that the command line is directing text output to %OutputFile%.  This placeholder will be replaced 
with the name of a text file to create. 
 
Note that this sample command line is specific to the nfbtrans utility.  Other converter programs will 
handle the input and output filenames on the command line differently.  You will need to consult 
documentation for your converter program to find  out how it handles input and output file names on the 
command line.  
 

 

Audio Device Selection 

 

 

 

Advanced Settings 

 
The Advanced Settings dialog is available for some settings that should be changed only under special 
circumstances.  Normally these settings should be left at their default values. 
 
The following settings can be changed on the Advanced Settings dialog: 
 
Use Direct Encoding when writing audio files 
Direct Encoding is a feature used with SAPI5 voices that allows TextAloud to write audio files without 
creating intermediate wav files.  The Direct Encoding option defaults to Enabled, and should be disabled 
only if you are having problems with it.  
 
Raise processing priority when speaking aloud 
This setting controls whether the Windows processing priority of TextAloud is raised when speaking text 
aloud.  When the option is enabled, your system will give TextAloud priority over other processes on your 
system, and allow the CPU to be used for longer intervals than normal priority processes.  The setting 
defaults to enabled, and prevents some stuttering that can occur when the setting is not used on slower 
systems. 
 
Raise processing priority when writing audio files 
This setting is identical to the previous setting, except that it apples when writing audio flies rather than 
speaking text aloud.  Increased processing priority is normally not needed when writing audio files, and 
defaults to disabled.  
 

 

Configure Spell Check 

 
The Spelling Options dialog is used to configure spell checking in TextAloud. 
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Numbered areas on the picture above indicate key areas, and are described below. 
 
1. Options 



The options in this section of the window control whether or not TextAloud will perform spell checking 
and/or make corrections as you type.  Also, you can configure various options, such as ignoring words 
containing numbers and ignoring words that are all uppercase. 
 
The option "Suggest from main dictionaries only" refers to items 2 and 3 below.  Selecting this checkbox 
limits suggestions from your main dictionaries only; your custom dictionary will not be used to generate 
suggestions. 
 
2. Main Dictionaries 
The dictionaries indicated here are your main dictionaries.  By default, TextAloud ships with the dictionary 
named american.adm, for US English.  Other dictionaries are available for download. 
 
3. Custom Dictionary 
The dictionary indicated here is your custom dictionary, and includes the following entries:  

  Words previously indicated as spelling errors that you Added to the spell checker  

  Any words marked for automatic correction.  The Custom Dictionary is updated with automatic 

corrections any time you click "Auto-Correct" on the Spelling dialog.  
 
By default, your custom dictionary name will be your windows user name, with the file extension ".adu". 
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Perform Spell Check 

 
Missing image: spelling.png 
 
The Spelling dialog is displayed when you click Perform Spell Check from the TextAloud Tools menu, and 
the spell check finds a misspelled word.  To correct the spelling, either select a spelling from the 
Suggestions list, or supply your own correction by typing it directly into the Replace With field.  Use either 
the Change or Change All buttons to apply the correction, depending on if you want to correct only a 
single occurrence or all occurrences of the spelling. 
 
The following buttons are available on the Spelling dialog: 

Button  Description  

Ignore  Ignore this occurrence of the misspelled word.  

Ignore All  Ignore all occurrences of the misspelled word.  

Change  Replace this occurrence of the misspelled word with the word in the 
Replace With field.  

Change All  Replace all occurrences of the misspelled word with the word in the 
Replace With field.  

Add  Adds the misspelled word to your custom dictionary. Future spell 
checks will no longer detect this word as an incorrect spelling.  

Auto-
Correct  

The Auto-Correct button will add both the misspelled word along with 
the correct spelling to your custom dictionary. Future spell checks will 
correct the error automatically. If the option "Correct spelling errors as 
you type" is selected in Spelling Options, the misspelled word will be 
automatically corrected whenever you type it.  



Undo  Undo the last change you made with either the Change or Change All 
button.  

Options  Displays the Configure Spell Check dialog.  

Cancel  Cancels the spell check.  
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Shortcut Setup 

 
The Shortcut Setup dialog is used to assign keyboard shortcuts to items in the TextAloud menu. 
 
Use the "Categories" dropdown list at the top of the dialog for filtering the menu items displayed.  The 
category "All Categories" will display all items in the TextAloud menu.  You can alternatively limit the 
items displayed by selecting a category for a specific main menu entry. 
 
Assigning a keyboard shortcut to a TextAloud menu item 
 
Select a menu item from the list of displayed items, and select Edit -> Edit Shortcut from the menu, or 
click the "Edit Shortcut" button on the toolbar.  On the prompt displayed, press the keystroke or 
combination of keystrokes you would like to assign as a shortcut, and click OK. 
 
If you need to remove the keyboard shortcut from a menu item, use Edit -> Clear Shortcut from the 
Advanced Toolbar Customization menu.  You can also use the "Clear" button on the Edit Shortcut dialog. 
 
Printing your keyboard shortcut list 
 
To print a list of your keyboard shortcuts, click File -> Print from the Shortcut Setup menu. 
 

 

 

Toolbar Icon Customization 

 
The Toolbar Icon Customization dialog is used for assigning your own icons to TextAloud toolbar buttons 
 
Use the "Categories" dropdown list at the top of the dialog for filtering the menu items displayed.  The 
category "All Categories" will display all items in the TextAloud menu.  You can alternatively limit the 
items displayed by selecting a category for a specific main menu entry. 
 
Assigning a custom icon to a TextAloud toolbar button 
 
Select a menu item from the list of displayed items, and select Edit -> Edit Icon from the menu, or click 
the "Edit Icon" button on the toolbar.  Use the File Open menu to pick an icon file (.ico) for the selected 
menu item. 
 
If you need to remove the icon from a menu item, use Edit -> Clear Icon from the Advanced Toolbar 
Customization menu.  



 

 

Pronunciation Dictionary Maintenance - Main Window 

 
The Pronunciation Dictionary Maintenance window is split into two sections.  The left side of the window 
contains a list of Dictionaries.  The right side of the window contains the Dictionary Entries that exist for a 
selected Dictionary. 
 
The menu / toolbar on the main window allows you do perform the following functions: 

  Add, Edit and Delete Dictionaries  

  Change Dictionary processing order  

  Filter Dictionary Entries displayed for a selected dictionary  

  Add, Edit and Delete Dictionary Entries  

  Change Dictionary Entry processing order  

  Enable and Disable selected Dictionary Entries 
 
Note that TextAloud will process Dictionaries and Dictionary Entries in the order specified in the 
Pronunciation Dictionary Maintenance Window. 
 
To Add a Dictionary 
Click File -> New Dictionary on the menu or click the New Dictionary button on the toolbar.  The Add 
Dictionary dialog will be displayed, allowing you to create the dictionary, and optionally associate a 
Language, Speech Engine Vendor, or a specific voice with the Dictionary. 
 
To Edit a Dictionary 
Select a Dictionary to edit, and click Edit -> Edit Dictionary on the menu, or click the Edit Dictionary button 
on the toolbar.  The Edit Dictionary dialog will be displayed, allowing you to edit the Dictionary caption, or 
the Language, Speech Engine Vendor and/or Voice associated with the Dictionary. 
 
To Delete a Dictionary 
Select a Dictionary to delete, and click Edit -> Delete Dictionary on the menu, or click the Delete 
Dictionary button on the toolbar.  This will permanently remove the Dictionary and all associated 
Dictionary Entries. 
 
To Change the Dictionary processing order 
Select a Dictionary and click Edit -> Move Dictionary Up or Edit -> Move Dictionary Down.  You can also 
use the Move Dictionary Up and Move Dictionary Down buttons on the toolbar.  TextAloud always 
processes dictionaries in the order they are displayed in the Pronunciation Dictionary Maintenance 
window. 
 
To Enable or Disable a Dictionary 
Select a Dictionary and toggle the enabled checkbox for the row.  Or select a Dictionary and tap the 
spacebar.  When applying pronunciation corrections TextAloud will use only enabled Dictionary Entries 
for enabled Dictionaries. 
 
To Filter Dictionary Entries displayed for a Dictionary 
Dictionary entries are always processed in the order they appear in Pronunciation Dictionary 
Maintenance, meaning TextAloud does not force the list to be sorted in any particular order.  A Filter is 
available in Pronunciation Dictionary Maintenance to limit the entries displayed to those that match a 
specified filter.  This makes it easier to locate specific entries in large dictionaries, while maintaining the 
dictionary entry processing order.  To display the Filter Panel, toggle the menu entry View -> Show Filter 



Panel, or toggle the Show Filter panel on the Dictionary toolbar.  The filter allows you to specify 
combinations of Caption, Text Matching and Pronounce Using, and allows you to specify whether full or 
partial matches are required.  Click the Apply Filter button to apply a filter, and the Remove Filter button 
to remove the filter.  When the filter is applied, the status bar at the bottom of the window is updated with 
the status "Filter Applied", and dictionary entries that do not match the filter are hidden. 
 

 
The steps for creating and maintaining Dictionary Entries is very similar to the steps for creating and 
maintaining Dictionaries. 
 
To Add a Dictionary Entry 
First, select a Dictionary you would like to create an entry for.  Click File -> New Entry on the menu or 
click the New Entry button on the toolbar.  The Add Dictionary Entry dialog will be displayed, allowing you 
to create a new Dictionary Entry for the selected Dictionary. 
 
To Edit a Dictionary 
Select a Dictionary Entry to edit, and click Edit -> Edit Entry on the menu, or click the Edit Entry button on 
the toolbar.  The Edit Dictionary Entry dialog will be displayed, allowing you to edit the Dictionary Entry. 
 
To Delete a Dictionary Entry 
Select a Dictionary Entry to delete, and click Edit -> Delete Entry on the menu, or click the Delete Entry 
button on the toolbar.  This will permanently remove the Dictionary Entry. 
 
To Change the Dictionary Entry processing order 
Select a Dictionary Entry, and click Edit -> Move Entry Up or Edit -> Move Entry Down.  You can also use 
the Move Entry Up and Move Entry Down buttons on the toolbar.  TextAloud always processes Dictionary 
Entries in the order they are displayed in the Pronunciation Dictionary Maintenance window. 
 
To Enable or Disable a Dictionary Entry 
Select a Dictionary Entry and toggle the enabled checkbox for the row.  Or select a Dictionary Entry and 
tap the spacebar.  You can also select multiple Dictionary Entries and enable/disable all entries at once 
using the Enable Entry and Disable Entry buttons on the toolbar.  When applying pronunciation 
corrections TextAloud will use only enabled Dictionary Entries for enabled Dictionaries. 
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Add/Edit Dictionary 

 
This dialog is used for creating and editing Pronunciation Dictionaries. 
 
The following fields are available on the Add/Edit Dictionary Dialog: 

Field  Description  

Dictionary 
Name  

A unique name used to identify the Dictionary. This is the name that 
will appear in the Dictionary list displayed in the Pronunciation 
Dictionary Maintenance main window.  

Optional 
Description  

A description of the Dictionary. This field may be left blank.  



Dictionary is 
Enabled  

A checkbox indicating whether or not the Dictionary is enabled. 
When applying pronunciations, TextAloud will only process enabled 
Dictionary Entries from enabled Dictionaries.  

Language  The language that this dictionary is associated with. A wildcard 
character (asterisk) is used to indicate that the dictionary is 
associated with all languages.  

Dialect  This field is enabled only if the Dictionary is associated with a 
specific language (see above). You have the option of associating 
the dictionary with a specific dialect for the selected language, or 
you may select "Use All Dialects" to associate the Dictionary with 
all dialects of the language.  

Vendor  The speech engine vendor that this dictionary is associated with. A 
wildcard character (asterisk) is used to indicate that the dictionary is 
associated with all vendors.  

Voice  The voice that this dictionary is associated with. A wildcard 
character (asterisk) is used to indicate that the dictionary is 
associated with all voices.  

Allow 
Overrides on 
Dictionary 
Entries  

This option controls whether or not the language, vendor, and voice 
associations for a Dictionary may be overridden on individual 
Dictionary Entries. If the Allow Overrides option is selected, you will 
have the option of setting language, vendor and voice associations 
when creating and editing Dictionary Entries. Associations specified 
for the Dictionary will be used as defaults for new Dictionary 
Entries.  

 

 

 
We recommend that you leave the option "Allow Overrides on Dictionary Entries" unchecked, and create 
separate dictionaries as needed to handle problems with specific languages, vendors, and/or voices. 
Leaving the option unchecked simplifies the Dictionary Entry Edit dialog, since the Language, Vendor and 
Voice fields are not displayed on the dialog. 
 
You may, however, find it more convenient to limit the number of Dictionaries, and specify Language, 
Vendor and Voice associations at the Dictionary Entry level. 
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Add/Edit Dictionary Entry 

 
This dialog is used for creating and maintaining Pronunciation Dictionary Entries.  The top half of the 
dialog contains the main fields for the Dictionary Entry; a tab control near the bottom of the dialog is used 
for testing pronunciations, and saving a description of the of the Dictionary Entry. 
 
Excluding the tab control for now, the fields on the Dictionary Entry dialog include: 

Field  Description  



Text Matching  Specifies one of three different text matching methods, depending 
on the dropdown list selection. Text Matching methods include 
Simple Text, Mask, and Regular Expression.  

Pronounce 
Using  

Indicates whether matched text should be replaced by an alternate 
spelling, replaced by a string of SAPI5 phonemes, spelled out, or 
skipped.  

Word 
Boundary 
Condition  

For Simple Text matches, this field indicates whether word 
boundaries should be required for a match to be successful.  

Case 
Sensitive  

If this option is checked, text matching is case sensitive. Note that 
the checkbox is used for Simple Text as well as Masks and Regular 
Expression matching.  

Caption  Specifies a name that uniquely identifies the Dictionary Entry in the 
current Dictionary. (The same caption may be used in different 
dictionaries). The caption will default based on the text entered in 
the Text Matching field.  

 

 
If the Dictionary for the current Dictionary Entry allows association overrides on Dictionary Entries, the 
Dictionary Entry dialog will also contain Language, Dialect, Vendor and Voice fields.  Associations 
specified for the Dictionary will be used as default values for Dictionary Entry Associations. 
 

Field  Description  

Language  The language that this dictionary entry is associated with. A wild card 
character (asterisk) is used to indicate that the dictionary entry is 
associated with all languages.  

Dialect  This field is enabled only if the Dictionary Entry is associated with a 
specific language (see above). You have the option of associating the 
dictionary entry with a specific dialect for the selected language, or 
you may select "Use All Dialects" to associate the Dictionary Entry 
with all dialects of the language.  

Vendor  The speech engine vendor that this dictionary entry is associated 
with. A wild card character (asterisk) is used to indicate that the 
dictionary entry is associated with all vendors.  

Voice  The voice that this dictionary entry is associated with. A wild card 
character (asterisk) is used to indicate that the dictionary entry is 
associated with all voices.  

 

 
The tab control near the bottom of the Dictionary Entry dialog has two tabs: Test Pronunciation and 
Description. 
 
The Test Pronunciation tab is used for testing a pronunciation.  Enter some text into the text box, choose 
a voice to test with, and press the Test button.  The pronunciation correction specified by the Dictionary 
Entry will be applied to the test text, allowing you to hear what the result sounds like. 
 
The Description tab is used to save a description of the Dictionary Entry.  It is sometimes easy to forget 
why a pronunciation correction was made in the past; the description field allows you to save some 
information about the pronunciation correction for later reference. 
 



Setting Text Matching for a Dictionary Entry 
 
When setting the Text Matching fields for a Dictionary Entry, the general idea is to use Simple Text when 
a specific word, or specific string of text is causing pronunciation problems.  You'll want to look at Masks 
or Regular Expressions when the pronunciation problem you're dealing with is not just one word, but 
rather a set of many words that have a common pattern.  For example, if a voice was having a problem 
pronouncing year numbers that start with 19, you would want to use a pattern match that looks for 4 digit 
numbers starting with 19.  You would use either a Regular Expression or Mask to handle this.  Regular 
Expressions and Masks are described in more detail here. 
 
Setting Pronounce Using for a Dictionary Entry 
 
Pronounce Using lets you select one of four different methods for performing pronunciation corrections. 
 
Respell - The Respell option is the most commonly used correction method, and allows you to replace 
matched text with an alternate spelling.  In the text field, enter a word or phrase that sounds like the 
pronunciation you want.  For example, if a speech engine is having trouble pronouncing the word "laugh", 
you could try using the alternate spelling "laf". 
 
Respell also has some limited support for functions and replaceable parameters.  See Respell Functions 
and Replaceable Parameters. 
 
Phonemes- Phonemes can be thought of as the smallest units of sound that a speech engine is capable 
of making.  Creating a phoneme pronunciation correction involves constructing the pronunciation you are 
trying to archive from these low level sounds.  When applying the pronunciation to spoken text, TextAloud 
will instruct the voice engine to pronounce the word using the phonemes supplied, instead of the 
phonemes the voice would normally generate.  In order to use phonemes as a pronunciation correction, 
the following conditions are required: 

  Phoneme pronunciations are applied only for SAPI5 voices.  SAPI4 voices will ignore Dictionary 

Entries that use phoneme pronunciation corrections.  

  Each language has its own table of Phonemes, so Phoneme pronunciations can be defined only if a 

Language and Dialect are associated with the Dictionary Entry (or owning Dictionary). 
 
Each phoneme is represented by a few characters, sometimes just one character.  A valid phoneme 
string will consist of a set of phonemes for the associated language, separated by spaces. 
 
When Phonemes is selected as the Pronounce Using option, the Helper button to the right of the text field 
will be enabled.  Clicking the Helper button will display the Phoneme Helper dialog.  This dialog will 
display a table of phonemes for the associated language, and assist you with constructing a phoneme 
string. 
 
Spell Text - There are sometimes instances where a speech engine will pronounce an acronym or 
abbreviation as a word, instead of spelling it out.  Use the Spell Text option to force matched text to be 
spelled out instead of pronounced as a word.  When you select the Spell Text pronunciation option, there 
is no text to enter, so the text field will not be displayed. 
 
Skip Text - The Skip Text pronunciation correction will cause any matched text to be skipped; the text will 
not be sent to the speech engine to be spoken.  The Skip Text option can be used to suppress the 
pronunciation of text such as page numbers in documents, email header information, or any other text 
you do not wish to hear spoken. 
 
Setting Word Boundary Condition for a Dictionary Entry 
 



The Word Boundary Condition field is enabled for Simple Text matches only, and allows you to specify 
whether or not text matches are required to fall on word boundaries.  The default setting, Word Boundary 
Required, prevents substitutions from being performed on any text that is a substring of another 
word.  For example, entering an alternate pronunciation for the word "day" changes the pronunciation of 
"day" everywhere it appears as a word, but not in words like "today", "yesterday", etc. 
 
To allow pronunciation changes on substrings, use one of the settings Word Boundary Required On Left, 
Word Boundary Required on Right, or No Word Boundary Required. 
 
To illustrate how this works, the following table indicates how each setting of the Word Boundary 
Condition field effects a pronunciation change for the text "board".  In each cell of the table below, a "Yes" 
indicates the pronunciation change will be applied. 

   Word Boundary Condition  

Word In Text  Word Boundary 
Required  

Word Boundary 
Required on Left  

Word Boundary 
Required on Right  

No Word 
Boundary 
Required  

board  Yes  Yes  Yes  Yes  

boarding     Yes     Yes  

snowboard        Yes  Yes  

snowboarding           Yes  
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Phoneme Helper Dialog 

 
The Phoneme Helper dialog is used to build phoneme strings for pronunciation corrections.  This dialog is 
available from the Add/Edit Dictionary Entry Dialog when Phonemes is selected as the Pronounce Using 
option. 
 
The following fields are available on the Phoneme Helper Dialog: 

Field  Description  

Sounds Like  Enter any text in this field and press the Generate button to 
generate the phoneme string used to pronounce the text.  

Phonemes  The phoneme string to be returned to the Dictionary Entry 
window  

Voice  The voice to use when using the Test button on the window.  

 

 



Using the Phoneme Helper Dialog 
 
The Phoneme Helper Dialog is displayed by pressing the Helper button on the Add/Edit Dictionary Entry 
Dialog when the Pronounce Using option is set to Phonemes.  When the dialog is initially displayed, the 
text in the Text Matching field will be displayed in the Sounds Like field.  You can then use the Generate 
button to generate the phoneme string for this text, or any other text.  This allows you to load a list of 
phonemes that may sound close to the pronunciation you are looking for. 
 
SAPI5 Phoneme tables are language specific, and the Phoneme Helper dialog can be displayed only 
when a specific Language and Dialect have been assigned to either the Dictionary Entry, or the 
Dictionary that the Dictionary Entry belongs to.  The phoneme set for this language/dialect are displayed 
on the left side of the Phoneme Helper dialog. 
 
To insert phonemes from the table into the phoneme field, use your mouse to position the cursor in the 
phonemes field.  Scroll through the list of phonemes for the language for the sound you're looking for, and 
double click the entry.  As you double click phoneme entries in the table, the phoneme will be inserted at 
the current cursor position in the phonemes field. 
 
Note that the phonemes entered in the phoneme field must be separated by spaces. 
 
When you are satisfied with the phoneme pronunciation, click the OK button on the dialog.  The phoneme 
string you have entered will be copied to the Add/Edit Dictionary Dialog, and displayed in the Pronounce 
Using field. 
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Respell Functions and Replaceable Parameters 

 
When Respell is selected as the "Pronounce Using" option, some functions and replaceable parameters 
are supported in the pronunciation string. 
 
Functions are primarily available to be used when the Text Matching option of a Dictionary Entry is set to 
either Mask or Regular Expression.  Functions in the pronunciation string can be used to manipulate 
and/or convert the results of text matched by regular expressions. 
 
Functions 
##LowerCase(String) - Converts a string argument to lower case. 
 
Example of using a function 
If a passage of text is all upper case, some voices will spell the upper case text, instead of pronouncing 
as words.  To solve this problem, a regular expression can be set up to search the text for upper case 
words of some minimum length, and convert these words to lower case.  The dictionary entry could look 
something like this: 
 
Missing image: lower case function.png 
 
The regular expression will scan the text for uppercase words 3 characters or more in length.  '\b' is used 



in the regular expression to match only on word boundaries.  Each match is passed to the ##LowerCase 
function via $0, which corresponds to the text matched by the expression. 
 
Replaceable Parameters 
 
In addition to functions, the pronunciation string supports the following replaceable parameters: 

Replaceable Parameter  Description  

%Date%  The current date.  

%Time%  The current time.  

%DateTime%  The current date and time.  

%Year%  The current year.  

 

 
For example, if the pronunciation string contains the text %Year%, the current year will be substituted 
when the pronunciation is applied to any matched text. 
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Pattern Matching with Masks and Regular 
Expressions 

 
Masks and Regular Expressions can be specified in the Add/Edit Dictionary Entry Dialog by setting the 
Text Matching option to either Masks or Regular Expressions.  Masks and Regular Expressions are used 
when the pronunciation change you are trying to make from Pronunciation Dictionary Maintenance is not 
limited to a single word.  Instead, the pronunciation change applies to many words (or phrases) that have 
a common pattern. 
 
For example, if a voice was having a problem pronouncing year numbers that start with 19, you could set 
up a pattern match to scan text for 4 digit numbers starting with 19, and apply a pronunciation correction 
for any text that matches the pattern. 
 
If you are not familiar with the term, Regular Expressions are a pattern matching language used for 
searching and parsing text.  TextAloud help will not get into the detailed syntax of using Regular 
Expressions, but there is plenty of reference material available on the web.  You can started by clicking 
here.  
 
Masks 
 
Masks are not as powerful as Regular Expressions but provide similar capability.   Masks allow you to use 
some predefined Mask Characters for matching text.  For example, the mask 19## can be used to search 
for four digit year numbers starting with 19.  Masks associate a special meaning to the following 
characters: 



Mask Character  Description  

#  Matches any digit (0 thru 9).  

$  Matches any alpha character (a thru z and A thru Z).  

@  Matches any alpha-numeric character (a thru z, A thru Z, 
and 0 thru 9).  

?  Matches any character (wildcard).  

_ (underscore)  Matches any word boundary character (spaces and 
punctuation).  

 

 
Subpatterns 
 
Much of the power of using both Masks and Regular Expressions has to do with the ability of a matching 
pattern to contain subpatterns.  Subpatterns are delimited by parentheses (which may be 
nested).  Turning part of a pattern into a subpattern does two things: 
 
1. Allows the pattern to specify a set of variations that the pattern should match  A vertical bar is used as 
a delimiter for the different choices.  For example, the pattern 
 
day(time|light|break) 
 
will match the words "daytime", "daylight" and "daybreak". 
 
2. Substitutions can reference the actual text matched by a subpattern.  The reference is made by using a 
dollar sign ($) followed by a number that identifies the subpattern.  Subpatterns are counted, starting with 
the number 1, by counting open parentheses from left to right.  So if text contains the year numbers 1985 
and 1986, the following regular expression will match both year numbers: 
 
(19)(\d\d) 

 
In this case, the match pattern contains two subpatterns.  For the matching year numbers 1985 and 1986, 
$1 will be 19, since $1 references the first subpattern (the first set of open parenthesis).  However, $2 will 
be 85 for the match on year 1985, and 86 for year 1986, since $2 corresponds to the second 
subpattern.  The second subpattern corresponds to the to the last two digits of a four digit year number. 
 
The following Mask works exactly the same: 
 
(19)(##) 
 
Using subpatterns in your match pattern lets you specify which pieces of matched text should be included 
in your pronunciation correction. 
 
Examples 
 
The following examples will illustrate how to use a Mask or Regular Expression to adjust the 
pronunciation of year numbers.  The sample problem is to ensure that year numbers starting with 19 (like 
1987) are pronounced as "nineteen eighty-seven", and not "one thousand nine hundred and eighty-
seven". 
 
Example 1 - Year Number correction using a Mask 



 
To solve this problem using a mask, you set the following fields in the Add/Edit Dictionary Entry Dialog: 

  Set the Text Matching dropdown to "Mask".  

  For the mask value, use the following: 
 
  (_)19(##)(_) 

  Set the Pronounce Using dropdown to "Respell"  

  For the Pronounce Using text, enter: 
 
  $1nineteen $2$3 
 
The pattern specified by the mask is a leading word separator, followed by the string "19", two digits, and 
another word separator.  Word separator characters are used to ensure that only four digit year numbers 
are adjusted.  Any other text containing 4 digits, like a phone number, will not be effected.  Also note that 
the word separator mask characters are subpatterns, where the actual word separator character matched 
is replaced in the pronunciation.  This is important if the word separator character happens to be a 
punctuation character.  So if the year number occurs at the end of a sentence, and is immediately 
followed by a period, the trailing period will be included in the pronunciation. 
 
Example 2 - Year Number correction using a Regular Expression 
 
To solve the same problem using a Regular Expression, do the following: 

  Set the Text Matching dropdown to "Regular Expression".  

  For the mask value, use the following: 
 
  (\b)19(\d\d)(\b) 

  Set the Pronounce Using dropdown to "Respell"  

  For the Pronounce Using text, enter: 
 
  $1nineteen $2$3 

 
The use of a regular expression is very similar to a mask in this case.  The "\b" strings in the Regular 
Expression match word separators, and the "\d" strings match the digits 0 thru 9. 
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File Splitter Utility 

 
The File Splitter Utility allows you to split very large documents.  You have the option of splitting the 
document into multiple, smaller text files, or sending the split output directly into multiple TextAloud 
articles.  You can use the File Splitter to split a file that is several megabytes in size to a size that is more 
easily handled by TextAloud articles.  If you're creating MP3 or WMA files to download to a portable 
player, it is often useful to create multiple small audio files (for example, one audio file per chapter) 
instead of one very large MP3 / WMA file. 



 
The following fields are available on the File Splitter Utility Window: 

Field  Description  

Input File Path  The name of the document to split. The entire path name must 
be specified.  

Write Split Text 
To  

Allows you to direct split output to text files or TextAloud articles.  

Output File 
Directory  

The directory to use when split output is directed to text files. An 
existing directory must be specified. This option is disabled when 
writing split text to TextAloud articles.  

Base Output 
Name  

The base name used for assigning names to split output. Each 
split name consists of a base name and sequence number. The 
base name should not contain a directory path or file extension.  

Starting Output 
Sequence 
Number  

The starting sequence number to be prefixed or appended to the 
base name. Each split name will be identified with a unique 
sequence number, starting with this initial number.  

Output Naming  Specifies whether sequence numbers should be prefixed or 
appended to the base name.  

Split Method  Allows you to select whether splitting will be performed by size, 
paragraph, or keyword.  

 

 
The split options displayed in the window depend on the Split Method selected. 
 
Split By Size Options 

Field  Description  

Target Split Size  The target split size in kilobytes. The split will actually occur at 
the nearest split boundary specified.  

Split Boundary  The Split Boundary is used along with the Target Split Size to 
determine where splits will occur in the document.  

 

 
Split By Paragraph Options 

Field  Description  

Split Every  Specifies the number of paragraphs to be contained in each 
split.  

Paragraph Marker  Used to specify the number of newlines that indicate the start 
of a new paragraph.  

 

 
Split By Keyword Options 
 
When Split By Keyword is selected as the Split Method, an Add/Remove list is displayed on the File 
Splitter window, allowing you to create a list of keywords.  The document will then be split at every 
occurrence of each keyword in the list.  When adding a keyword to the list, a dialog containing the 
following fields is displayed: 



Field  Description  

Keyword  Specifies a keyword to split at.  

Split Option  Specifies how the keyword should be handled when performing splits. 
You can specify that text should be split before or after the keyword, 
meaning that the keyword is left in the text at the end of a split, or at 
the beginning of the next split. You also have the option of excluding 
the keyword from splits.  

 

 

 

 

Batch File Converter 

 
The Batch File Converter is a tool that allows you to select many document files and convert them all to 
audio files.  The utility supports all document formats supported by Document Import. 
 
The following fields are available on the Batch File Converter dialog: 

Field  Description  

Output 
Directory  

The directory where audio files will be written. An existing directory 
must be specified.  

PDF Text 
Encoding  

For PDF documents, this setting indicates whether or not the text 
extraction process should treat the PDF document as Unicode. The 
'Default' setting will normally work for US English and European PDF 
documents.  

Audio File 
Format  

Select an audio format from one of the available encoders on your 
machine. The most commonly used audio formats are MP3 and 
WMA.  

Bit / Sample 
Rate  

This setting is used to determine the quality of audio files generated 
by TextAloud. The setting "Default for Voice" can be used to have 
TextAloud automatically choose a Bit/Sample rate setting based on 
the type of audio produced by the voice.  

Voice 
Selection  

Allows you to control how voices are selected for writing audio files: 

Select 
Allows you to choose a single voice used to generate all audio files. 

Random 
TextAloud will choose a random (enabled) voice for each audio file. 

Round Robin 
TextAloud will choose a voice for each audio file by sequentially 
stepping through your enabled voices.  

Voice  This field is enabled only if Voice Selection is set to Select. Use this 
field to determine which voice will be used for writing audio files.  

Add Audio to 
iTunes 
Playlist  

Specifies whether audio files created by the Batch File Converter will 
be automatically added to iTunes in the specified Playlist. This option 
is available only if iTunes is installed, and the Audio File Format is an 
MP3 format.  



 

 
To Build a list of files to convert 
Use File -> Add Files and File -> Remove Selected to add and remove files from the Batch File Converter 
window.  If you decide to start over, you can use File -> Clear to remove all files from the window and 
begin again. 
 
To Start converting files 
Once you have finished building a list of files to convert, select Tools -> Convert from the menu, or click 
the Convert button on the toolbar.  This will disable the Add, Remove and Clear menu entries / toolbar 
buttons, and begin the audio file conversion process. 
 
To Change Batch File Encoder Options 
The fields Audio File Format and Bit / Sample Rate are located on Batch File Converter window, but other 
File Options are available by clicking Tools -> Batch Audio Options from the menu.  File Options, Custom 
Encoders, Audio Tags and Background Audio options are available on the tab panels; the settings on 
these options panels apply only when using Batch File Conversion. 
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  If you are not sure which Audio Format to use, we recommend using either an MP3 or WMA format.  

  If you are not sure which Bit / Sample rate to use, try using the "Default For Voice" selection. 
 
Missing image: tdoc4.bmp Note 
If you have voices for multiple languages installed, the Random and Round Robin voice selection options 
will choose voices based on the Language and Dialog settings on the Voice Options panel. 
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TextAloud Setup Wizard 

 
The TextAloud Setup Wizard steps you through some basic TextAloud configuration options.  The options 
configured by the setup wizard are all available under the TextAloud View menu. 
 
If you are running TextAloud for the first time, and not sure about which settings to pick, just select all the 
defaults.  You can always rerun the setup wizard later from the TextAloud Tools menu, or configure 
individual settings beneath the TextAloud View menu. 
 
Options configured by the Setup Wizard include: 

  Toolbars displayed in the main window  

  Whether or not to display a dropdown list of articles loaded in TextAloud  

  The size of buttons (small, medium, or large) used in the TextAloud toolbars  



  Whether or not to display button captions in TextAloud toolbars. 
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Article 

 
An "Article" in TextAloud is the text area displayed in the main window, beneath the toolbars.  As multiple 
articles are added to the TextAloud window, each article is displayed in a separate tab.  The speaking 
functions of TextAloud speak the text loaded in an article. 
 
There are several ways of loading text into an article.  Articles can be loaded via: 

  TextAloud watching the Windows Clipboard  

  TextAloud watching your mouse for text selections  

  Document Import (File -> Open)  

  Import HotKeys  

  Drag and Drop  

  "Open With TextAloud" from the Windows Explorer context menu. 
 
For more details on each of these methods, see Loading Articles.  
 

 

Audio Tag 

 
Data stored in an audio file that contains information about the contents of the audio file.  Tags include 
information such as artist, album, track number, etc.  
 

 

Bit Rate 

 
Bit rate is measured in kbps, or kilobits per second.  For audio files this rate corresponds directly to file 
size: larger bitrates mean larger audio files, and generally longer encoding times. 
 
For suggestions on choosing Bit Rates and Sample Rates for your audio files, see the File Options panel 
help.  
 

 

Direct Encoding 

 
Direct Encoding is a TextAloud feature that generates audio files from text without relying on intermediate 
wav files.  When Direct Encoding is used, spoken audio is encoded real time, as the audio is 
produced.  When Direct Encoding is not used, spoken audio is written to intermediate wav files, and then 
converted to audio in a two step process.  Direct encoding is generally much faster than generating audio 
files with intermediate wav files. 
 



TextAloud supports Direct Encoding with SAPI5 voices only.  When TextAloud creates audio files with 
SAPI4 voices, intermediate wav files are used, and the encoding is slower.  
 

 

MP3 

 
MP3 is short for Motion Picture Experts Group, Audio Layer 3. MP3 produces CD-quality sound in a 
compressed file that can be transferred quickly, and played on any multimedia computer with MP3 player 
software.   
 

 

Phoneme 

 
A phoneme is one of the smallest units of sound that a speech engine is capable of making.  Speech 
engines group phonemes into words and sentences, which we hear as speech.  Each language has its 
own set of phonemes.  
 

 

Profile 

 
A profile in TextAloud is basically a name that identifies a specific way that TextAloud is being 
used.  There are currently three profiles defined in TextAloud: Normal Speaking, Vocal Proofreading, and 
Step Proofreading. 
 
Profiles are used to enable/activate features in TextAloud based on usage, or the text being spoken.  
 

 

Sample Rate 

 
When you listen to digital audio, you are actually listening to many discrete 'samples' of sound. Sample 
rate is a measure of the number of samples per second, and can be thought of as the resolution or 
accuracy of the audio. A high sample rate means that the resolution of the recording is high, thus very 
"accurate". Digital music is typically recorded at sample rates of 44.1kHz and higher. Digital speech can 
use much lower sample rates without loss of sound quality. High quality speech can be generated at 
16kHz; telephony applications use a sample rate of 8kHz. 
 
One kiloHertz (kHz) is one thousand cycles per second. 
 
For suggestions on choosing Bit Rates and Sample Rates for your audio files, see the File Options panel 
help.  
 

 

SAPI 

 
SAPI is Microsoft's Speech Application Interface, and is an interface for application programs like 
TextAloud to interact with speech engines.  There are currently two versions of SAPI available, SAPI4 
and SAPI5.  Both interfaces are supported by TextAloud, but there are some differences in available / 
implemented features. 



 
The following table summarizes the main differences between using SAPI4 and SAPI5 speech engines in 
TextAloud: 

Engine Feature  SAPI4 
Support  

SAPI5 
Support  

Pause Tags (manually inserted / automatically 
generated)  

Most 
Voices  

Yes  

Phoneme support in Pronunciation Dictionary 
Maintenance  

No  Most 
Voices  

Support for Speed, Pitch, Volume, Spell and Voice 
switching tags in TextAloud articles  

No  Yes  
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Step Proofreading 

 
Step Proofreading is a proofreading mode in TextAloud that takes place within a TextAloud article instead 
of in a separate proofreader window.  Step Proofreading is initiated by selecting one of the Step 
Navigations beneath the Navigations menu.  When a single 'step' has finished speaking, TextAloud will 
then pause, allowing you to either step again, or resume normal speaking. 
 
TextAloud remains in Step Proofreading mode until either the Resume button is pressed, or when the end 
of the article is reached. 
 
See Proofreading Documents.  
 

 

Vocal Proofreading 

 
Vocal Proofreading is a way of proofreading documents in TextAloud, using a standalone proofreader 
window.  Vocal Proofreading is initiated by selecting text in any application, and copying the text to the 
proofreader window using a Hotkey, the Clipboard Prompt, or the Mouse Speak Prompt. 
 
See Proofreading Documents.  
 

 

Windows Clipboard 

 
The Windows Clipboard is a standard part of the Windows operating system, and is used as a short-term 
storage area for text and/or images.  Whenever you "Cut" or "Copy" something from an application, the 
information is placed on the Windows Clipboard.  Applications commonly offer a "Paste" function that 
allows information on the clipboard to be inserted into the application. 
 



TextAloud monitors the Windows Clipboard for changes, allowing the clipboard to be used to transfer text 
from any application to a TextAloud article.  The clipboard can contain both text and image data, but 
TextAloud extracts text only, ignoring any images.  So copying text into TextAloud can be done just by 
highlighting an area of text in an application, and pressing Ctrl+C to "Copy" the text to the clipboard. 
 
The Windows Clipboard is used for many purposes on your computer, such as copying and pasting text 
within a word processor application.  TextAloud will be aware of these clipboard updates, and by default, 
an alert dialog will prompt you to copy clipboard changes into TextAloud.  Use the Clipboard Options 
panel to control when TextAloud displays the alert.  For example, you can configure the alert to display 
only if the amount of text on the clipboard exceeds a minimum size.  
 

 

WMA 

 
The Windows Media Audio format for digital sound, launched by Microsoft as an alternative to the MP3 
format. You may hear better sound quality from MP3 files, but WMA compression is generally better, so 
WMA files tend to be smaller than MP3 files.   
 


